libc.so.6: версия 'GLIBC_2.16' не найдена

6

При импорте библиотеки (cdms2) в python появляется следующее сообщение об ошибке:

ImportError: /lib/x86_64-linux-gnu/libc.so.6: version 'GLIBC_2.16' not found (required by /usr/local/uvcdat/1.3.1/Externals/lib/libcurl.so.4)

Моя версия libc6 в настоящее время 2.15 (Ubuntu 12.04). Я понимаю, что новая версия не находится в стабильном репозитории: как я могу заставить apt обновиться до версии 2.16?

    
задан Bruno von Paris 03.07.2013 в 16:17
источник

2 ответа

6

Существует более безопасный способ запуска одного приложения. Проблема заключается в том, что в то время как glibc предназначен для обратной совместимости, он не является на 100% точным. Проблемы известны. Таким образом, не обновляйте библиотеку по всей системе. Вместо этого подготовьте целый набор обновленных библиотек. Поместите их, скажем, / catbed . Затем просто запустите

   /catbed/ld-linux.so.3 --library-path=/catbed:/whatever-else /usr/bin/python -python-args

Из-за причин адаптируйте имена файлов к вашему делу. Это намного безопаснее, потому что, если вы испортите свою пару ld-linux + libc , вы не сможете ее исправить изнутри ОС. Тогда у вас будут трудные времена, даже тогда, когда они будут chrooting. Я регулярно использую трюк для старых проприетарных Linuxes (gcc 3.1, kernel 2.3), на которых я хочу запустить Qt5.     

ответ дан Barafu Albino 12.07.2013 в 16:32
источник
0
  

Была ли установлена ​​установка UVCDAT вручную или загружена   предварительно построенные двоичные файлы?

Биннары UVCDAT 1.3.1 были построены на платформе Ubuntu 13.04. Даже если вы решите эту проблему, может возникнуть множество других ошибок. Попробуйте загрузить ​​UVCDAT 1.2 . Если вы хотите получить последнюю версию UVCDAT и хотите придерживаться 12.04, попробуйте создать исходный код. Обновите ОС до 13.04 и используйте последнюю версию UVCDAT 1.4.1.     

ответ дан Rajeev 18.09.2013 в 07:42