Пара Bose QuietComfort 35 с Ubuntu по Bluetooth

52

В Системные настройки > Bluetooth , Bose QC 35 отображается при поиске устройств, но спаривание не выполняется.

После нескольких попыток и воспроизведения с параметрами PIN мне удалось соединить его, но после выбора в System Settings > Звук , он потерпит неудачу и вернется к встроенному аудио или воспроизведет какой-то искаженный звук.

    
задан Victor 05.10.2016 в 12:20
источник

3 ответа

107

Кажется, у Bose Quiet Comfort 35 есть проблемы с сопряжением с Bluetooth LE (Low Energy) .

Вернитесь в чистое состояние

Я бы рекомендовал очистить вас от попыток пары:

  • В Ubuntu удалите наушники из списка парных Bluetooth.
  • В наушниках удерживайте переключатель в позиции Bluetooth в течение 10 секунд, чтобы удалить все сопряженные устройства (вы получите голосовое подтверждение).
  • Если вы можете, отключите Bluetooth на других окружающих устройствах, чтобы убедиться, что они не будут взаимодействовать.

Отключить Bluetooth LE

Изменить конфигурационный файл Bluetooth:

sudo nano /etc/bluetooth/main.conf 

Заменить:

#ControllerMode = dual

с:

ControllerMode = bredr

Перезапустите Bluetooth:

sudo service bluetooth restart

Пара

  1. Убедитесь, что наушники находятся в режиме сопряжения.
  2. Пара с Системные настройки > Bluetooth
  3. Выберите & amp; проверьте наушники в Системные настройки > Звук . Вы можете выбрать High Fidelity Playback (A2DP Sink) для высокого качества воспроизведения.

Повторно активировать Bluetooth LE (опционально)

Поскольку это сопряжение должно выполняться без Bluetooth LE, как только он будет спарен, вы можете вернуться к исходной конфигурации:

sudo nano /etc/bluetooth/main.conf 

Заменить:

ControllerMode = bredr

с:

#ControllerMode = dual

Перезапустите Bluetooth:

sudo service bluetooth restart

Устранение неполадок

Если у вас есть проблемы с подключением после отключения / перезагрузки:

  • Убедитесь, что компьютер и Bluetooth включены в наушники.
  • Если Соединение выделено серым цветом в Системные настройки > Bluetooth , вы можете использовать меню Bluetooth в строке меню (рядом с часами), чтобы выполнить Включение / выключение соединения .
ответ дан Victor 05.10.2016 в 12:20
источник
31

Принятый ответ не помог мне. Эта запись в блоге работала: Ссылка

  1. Создать /etc/bluetooth/audio.conf

    [General]
    Disable=Socket
    Disable=Headset
    Enable=Media,Source,Sink,Gateway
    AutoConnect=true
    load-module module-switch-on-connect
    
  2. В /etc/bluetooth/main.conf установлено

    ControllerMode = bredr
    AutoEnable=true
    
  3. Перезапустите bluetooth

  4. Подключите наушники
  5. Выберите High Fidelity Playback (A2DP sink) -mode в настройках звука
ответ дан Ohjeah 20.02.2017 в 03:18
1

Решение выше не работает для меня. Я получил его на работу, но вам нужно настроить его вручную при каждом перезагрузке.

  1. Сначала закройте bluetooth и bluez , эффективно остановив их (не перезапуская), а затем снова запустив их, используя systemctl start bluetooth и sudo /etc/init.d/bluetooth start .
  2. Запустите bluez manager и подключите устройство, используя настройку с профилем аудиосоединения.
  3. Вручную замените звук на наушники.

Я новичок со сценариями, может быть, кто-то более опытный, чем я, может сделать скрипт, который выполняет все эти действия при загрузке.

    
ответ дан Ale763 17.03.2017 в 12:00