Переход к определенному php 7.1 / 7.2 с php 7.0 в Ubuntu 16.04 [duplicate]

42

Как я могу перейти на php 7.1 с php 7.0 в ubuntu 16.04?

Если я делаю php -v , я получаю это сообщение:

PHP 7.0.8-0ubuntu0.16.04.3 (cli) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.8-0ubuntu0.16.04.3, Copyright (c) 1999-2016, by Zend Technologies
    
задан zioMitch 04.12.2016 в 09:21
источник

1 ответ

91

В репозиториях Ubuntu 16.04 нет официального PHP 7.1.

Если вы хотите PHP 7.1, есть версия, доступная в ppa: ondrej / php

Вы можете установить его так:

  1. sudo add-apt-repository ppa:ondrej/php
  2. sudo apt-get update
  3. (необязательно) sudo apt-get remove php7.0
  4. sudo apt-get install php7.1 (из комментариев)

Помните, что это не официальный путь обновления. PPA хорошо известен и относительно безопасен в использовании.

У PPA есть совместно устанавливаемые пакеты (у вас может быть установлено несколько версий PHP из этого PPA). ~ ответ дан ThatGuy 04.12.2016 в 09:31

источник