Как отключить Bluetooth при запуске системы?

281

Как отключить Bluetooth при запуске системы?

    
задан Floqqi 16.10.2011 в 21:02
источник

28 ответов

190

18.04+ пользователи, которые, естественно, не имеют /etc/rc.local, вам нужно создать его и сделать его исполняемым. Чтобы сделать что-то немного проще, вы можете просто вставить следующую команду в терминал:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Запустите sudoedit /etc/rc.local и добавьте это до строки с exit 0 :

rfkill block bluetooth

Вы все равно сможете включить Bluetooth через апплет верхнего бара.

Этот должен работать для большинства систем, но похоже, что в ядре ACPI для Thinkpads имеется несколько ошибок. Если вы используете Thinkpad, добавьте следующее в /etc/rc.local :

echo disable > /proc/acpi/ibm/bluetooth

Или зайдите в ibm-acpi - IBM ThinkPad ACPI Extras Driver - некоторые отчеты говорят о том, что ibm-acpi включает в себя управление bluetooth (среди других приятных вещей). Но у меня нет оборудования, поэтому я полностью не могу проверить эти претензии. Удачи.

    
ответ дан Oli 18.08.2010 в 09:00
73

Я нашел практическое руководство с чистым «обходным решением» здесь ( ссылка на архив для потомков)

На самом деле для меня было достаточно изменить /etc/bluetooth/main.conf .

Из статьи:

Поиск записи:

InitiallyPowered = true

и измените значение на:

InitiallyPowered = false

Этого было достаточно для меня, хотя в статье описаны некоторые другие шаги, которые могут или не могут быть необходимы.

В Ubuntu 17.10 и Ubuntu 18.04 опция InitiallyPowered была заменена на AutoEnable

    
ответ дан Stepbaer 25.06.2012 в 18:00
23

Чтобы отключить драйвер bluetooth при загрузке при запуске:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

добавить:

blacklist btusb

Включение этого позже должно быть только:

sudo modprobe btusb
    
ответ дан maco 18.08.2010 в 16:59
16

Шаг 1. Перейдите к терминалу и введите следующую команду, чтобы отредактировать файл /etc/rc.local системы:

gksudo gedit /etc/rc.local

Шаг 2: добавьте следующую строку до строки exit 0 :

rfkill block bluetooth
    
ответ дан Varun 04.05.2012 в 20:44
13

Начиная с ubuntu 16.04, система systemd управляет службами запуска, такими как bluetooth ... для просмотра текущей проблемы состояния, следующей в терминале

sudo systemctl status bluetooth.service 

для деактивации bluetooth при запуске этой проблемы

sudo systemctl disable bluetooth.service

, то при следующей перезагрузке bluetooth не будет активным ... для включения проблемы с Bluetooth.

sudo systemctl enable bluetooth.service
    
ответ дан Scott Stensland 01.08.2017 в 15:08
7

Введите в терминал следующее:

sudo gedit /etc/modprobe.d/blacklist.conf

В нижней части файла добавьте строку:

blacklist bluetooth

Сохраните файл и перезапустите - теперь Bluetooth должен быть отключен.

    
ответ дан Nathan Osman 16.10.2011 в 21:25
7

Вы можете изменить службы, запущенные при загрузке, с помощью BUM .

Установите его: sudo apt-get install bum

Выполнить: sudo bum

Снимите флажок и нажмите Применить .     

ответ дан desgua 05.05.2012 в 00:09
5

Я думаю, что лучший способ - отключить сервис от запуска в первую очередь. Существует общий метод отключения служб, который отлично работает:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

Это работает для Ubuntu 13.10 и, возможно, для более ранних версий.

    
ответ дан Felipe 18.01.2014 в 09:49
5

Я добавляю

"/etc/init.d/bluetooth stop"

в

"/etc/rc.local" 

перед командой «exit 0» для загрузки с отключенным Bluetooth.

    
ответ дан Saeed Zarinfam 23.08.2012 в 13:00
5

1. блочный bluetooth в rc.local

Добавьте эту строку в конец файла /etc/rc.local прямо перед строкой exit 0 :

rfkill block bluetooth

Это сделает трюк, но только в более старых версиях Ubuntu, используя выскочку .

2. reenable rc.local на systemd

В Ubuntu 15.10 с systemd в качестве менеджера запуска файл /etc/rc.local больше не используется по умолчанию, поэтому вызовите это на терминале:

sudo systemctl edit --full rc-local

Открывает редактор. В конце файла я добавил:

[Install]
WantedBy=multi-user.target

Эти изменения активируются

sudo systemctl reenable rc-local

Теперь файл /etc/rc.local используется, как вы его знаете.

3. отключить blueman-апплет при запуске

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/blueman.desktop
gnome-session-properties

Теперь blueman-апплет виден, и вы можете отключить его от программ запуска

4. Перезагрузите, чтобы увидеть эффект

    
ответ дан rubo77 10.11.2015 в 12:29
4

Вы можете отредактировать свои настройки update-rc.d . Я использовал что-то похожее на:

sudo update-rc.d bluetooth remove

В Debian Wheezy. Для получения дополнительных сведений о том, как его использовать, просмотрите man update-rc.d .

    
ответ дан Keith Smiley 13.02.2013 в 15:50
2

Возможно, вы можете отключить его в приложениях запуска. Но эти приложения скрыты по умолчанию. Покажите скрытые приложения для запуска в 12.04: откройте терминал и выполните следующие две команды:

cd /etc/xdg/autostart/

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

Теперь вы можете снять отметку с bluetooth. (Не удаляйте!)

    
ответ дан schiemanski 05.05.2012 в 08:50
2

Нет. Он не всегда находится в списке приложений для запуска. Я считаю, что лучшим решением является добавление команды rfkill в скрипт rc.local или установка параметра InitiallyPowered в /etc/bluetooth/main.conf .

    
ответ дан Robert 05.05.2012 в 00:06
2

1) Установите пакет smbios-utils и добавьте его в Запуск приложений с помощью

sudo smbios-wireless-ctl --bt 0

2) В типе терминала:

sudo visudo

и добавьте в конец открытого файла /etc/sudoers строку:

<your username> ALL = NOPASSWD: /usr/sbin/smbios-wireless-ctl

3) Чтобы включить Bluetooth во время сеанса, запустите в терминале:

sudo smbios-wireless-ctl --bt 1

Это работает для меня на моем Dell D630 с Ubuntu 13.10

    
ответ дан victor 15.03.2014 в 15:58
2

В Ubuntu 16.04 я просто отключил службу от запуска с помощью systemctl.

Для этого откройте окно терминала и введите следующее:

sudo systemctl disable bluetooth

Вы можете либо перезагрузиться, так как теперь bluetooth будет отключен от запуска, или если вы не хотите перезагружаться и хотите немедленно отключить Bluetooth, вы можете ввести:

sudo service bluetooth stop

    
ответ дан Ken 22.08.2017 в 03:57
2

Мы можем отключить автоматический запуск Bluetooth следующим образом:

sudo gedit /etc/bluetooth/main.conf

( gedit - мой редактор fav, вы можете заменить это xed или тем, что установлено в вашей системе.)

В самом низу этого файла есть следующая строка:

#AutoEnable=false

Отмените комментарий, например:

AutoEnable=false
    
ответ дан Shayan 20.02.2018 в 14:47
1

Я использую Ядро Спутника , которое исправлено на моем Dell Inspiron 14R N4110.

    
ответ дан Alex Wiedermann 24.09.2012 в 23:53
1

Думаю, вам следует отредактировать

/etc/default/bluetooth

и установите

BLUETOOTH_ENABLED=0

, чтобы отключить службу bluetooth при загрузке

    
ответ дан Fabio 06.03.2014 в 20:17
1

В Ubuntu Studio 16.04 вы можете отключить апплет Bluetooth при запуске в:

Session and Startup > Application Autostart > Bluetooth Applet

Здесь вы можете щелкнуть по полю, чтобы отключить его.

    
ответ дан ateymuri 26.08.2016 в 18:05
1

Для тех из вас, где вставка строки rfkill block bluetooth (или любого другого) в /etc/rc.local не работает, попробуйте включить ту же строку в конец ~/.bashrc

В моей настройке (Ubuntu 14.04, Thinkpad W540) никакая опция не включала ее в /etc/rc.local , но первая работала в bashrc. Обратите внимание, что это будет работать только для текущего пользователя, а не для всех пользователей.

    
ответ дан Sam 19.10.2014 в 12:10
0

Я добавляю

"/etc/init.d/bluetooth stop"

в

"/etc/rc.local" 

перед командой «exit 0» для загрузки с отключенным Bluetooth.

    
ответ дан Saeed Zarinfam 23.08.2012 в 13:05
0

Решение для моего ноутбука

"BIOS - Конфигурация USB - EHCI2: Отключено"

EHCI1 для портов usb (на самом деле у моего ноутбука есть 2 USB 2.0 порта)

    
ответ дан MSP 27.03.2014 в 18:46
0

Изменить /etc/default/grub :

sudo nano /etc/default/grub

и измените следующую строку:

GRUB_CMDLINE_LINUX=""

, чтобы сказать это:

GRUB_CMDLINE_LINUX="bluetooth.blacklist=yes"

Затем обновите grub и перезагрузитесь:

sudo update-grub
    
ответ дан mchid 21.09.2015 в 05:58
0

Это должно отключить запуск bluetooth в системах на базе Debian:

sudo chkconfig bluetooth off

или на системах на основе RedHat

systemctl disable bluetooth.service
    
ответ дан Stanislav 16.10.2017 в 20:18
0

Если вы используете апплет Bluetooth на верхней панели (blueman-апплет), у него есть свой собственный параметр, который автоматически включает Bluetooth, даже если вы отключили его в других местах (например, / etc / bluetooth / main .conf или / etc / default / tlp).

Чтобы предотвратить включение Bluetooth при запуске с помощью командной строки:

gsettings set org.blueman.plugins.powermanager auto-power-on false

Или через GUI:

  1. Нажмите апплет Bluetooth > Плагины > PowerManager > Конфигурация
  2. Снимите флажок Автоматическое включение питания

В следующий раз, когда вы перезагрузитесь, апплет Bluetooth по-прежнему будет виден, но Bluetooth будет выключен. Чтобы включить его:

Нажмите апплет Bluetooth > Включить Bluetooth

    
ответ дан bmaupin 27.07.2018 в 17:12
-1

Мне пришлось использовать метод грубой силы, чтобы остановить запуск bluetoothd при загрузке автоматически. Я переименовал исполняемый файл, чтобы его не удалось найти.

    
ответ дан bluesdiva2001 06.07.2012 в 01:02
-1

Вы также можете использовать это графическое приложение, которое также выполняет менеджер bluetooth

    
ответ дан deFreitas 27.12.2014 в 13:26
-3

Вам нужно отключить его из списка «Запуск приложений» в «Системные настройки».

Нажмите на шестерню в верхней правой части панели меню, а затем выберите «Настройки системы».

Нажмите «Запустить приложения», затем прокрутите вниз до тех пор, пока не найдете настройку Bluetooth, установите галочку в поле и все сделанное.

    
ответ дан Mark Rooney 16.10.2011 в 21:13