phpmyadmin не работает после того, как я его установил

49

Я использую ubuntu-11.04 .

Я выполнил следующие шаги на этом сайте:

Пока мои apache2, php и mysql отлично работают, кроме phpmyadmin ... Всякий раз, когда я запускаю это:

http://localhost/phpmyadmin/

Я получаю эту ошибку в своем браузере:

Not Found

The requested URL /phpmyadmin/ was not found on this server.


Apache/2.2.17 (Ubuntu) Server at localhost Port 80

    
задан Moron 01.08.2011 в 04:21
источник

10 ответов

105

Прочитайте этот раздел в вики Ubuntu. Вам нужно будет настроить apache2.conf для работы phpMyAdmin.

gksu gedit /etc/apache2/apache2.conf

Затем добавьте следующую строку в конец файла.

Include /etc/phpmyadmin/apache.conf

Затем перезапустите apache

/etc/init.d/apache2 restart
    
ответ дан JohanSJA 01.08.2011 в 05:12
источник
14

Пробовал разные способы.

Наконец, это из документации ubuntu работало для меня:

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
sudo a2enconf phpmyadmin
sudo service apache2 reload
    
ответ дан sangharsh 22.09.2015 в 11:29
5

Ubuntu 16.04

После установки и настройки пользователя и пароля в mysql и phpmyadmin выполните следующую команду

sudo apt install php-gettext

Работал для меня ...

Edit1 Если вам просто нужны apache, phPmyAdmin и MySql только для среды веб-приложений, то я предлагаю для примера, который устанавливает все три для вас, а затем вы готовы к работе. Вот ссылка

Установщики и загрузки XAMPP | Друзья Apache

    
ответ дан Rajat Verma 03.07.2016 в 08:52
3

Не паникуйте! Просто запустите следующий код с правами root в терминале

sudo ln -s /usr/share/phpmyadmin /var/www
    
ответ дан Hardik Thaker 13.02.2013 в 14:59
1

У меня возникла такая же проблема, я исправил ее, запустив sudo dpkg-reconfigure phpmyadmin

укажите новое имя пользователя и пароль

    
ответ дан Tachyons 13.02.2013 в 15:10
0

Вам нужно найти, где находится phpmyadmin , например. locate phpmyadmin, некоторые из них вернут местоположение, например /usr/share/phpmyadmin .

Затем вы можете символически ссылаться на это следующим образом: sudo ln -s /usr/share/phpmyadmin /var/www

Запуск Ubuntu 14.04 и выше, /var/www больше не работает вместо /var/www/html . например, sudo ln -s /usr/share/phpmyadmin /var/www/html

Ссылка: Где разместить мой локальный сайт, начиная с версии 2.4.7 apache2?

    
ответ дан Arman Ortega 21.06.2015 в 18:13
0
sudo sed -i '$ a\Include /etc/phpmyadmin/apache.conf' /etc/apache2/apache2.conf && sudo service apache2 restart && sudo apt-get install php-gettext'

Протестировано и работает. Выполнение этого должно решить его для всех, кто хочет 1 лайнер.

    
ответ дан Robert Pounder 30.11.2016 в 17:06
0

Я пробовал все вышеперечисленные методы, и они не работали для меня. Наконец, это работало.

Откройте терминал и переключитесь на суперпользователя с помощью команды: sudo su

После установки phpmyadmin с помощью инструкций, приведенных в ссылка , откройте /etc/apache2/conf-available .

Вы найдете файл с именем phpmyadmin.conf . Скопируйте его в /etc/apache2/conf-enabled . Или просто используйте команду

sudo cp /etc/apache2/conf-available /etc/apache2/conf-enabled

Перезапустите apache2 ( sudo service apache2 restart ), а затем откройте ссылку localhost / phpmyadmin в браузере.

    
ответ дан abeginner 23.02.2017 в 22:22
0

наконец, эта работа для ubuntu 14.04 LTS

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
sudo ln -s /usr/share/phpmyadmin /var/www/html/phpmyadmin
sudo service apache2 restart

теперь введите localhost/phpmyadmin в веб-браузере.

    
ответ дан shamsh nezam 12.10.2017 в 08:59
-3

Я столкнулся с той же проблемой.

Сначала проверьте, существует ли каталог с именем /usr/share/phpmyadmin/ . Если это так, просто переместите его в /var/www/phpmyadmin , выполнив следующую команду:

mv /usr/share/phpmyadmin /var/www/phpmyadmin

Откройте браузер и откройте http://localhost/phpmyadmin . Теперь он должен работать.

    
ответ дан Mariyah 26.07.2012 в 08:06