Сервер Ubuntu не использует настройки прокси-сервера

0

Я использую пакет сервера ubuntu (только терминал), и я изо всех сил пытаюсь заставить прокси-сервер работать.

для прокси-сервера нет имени пользователя / пароля.

Когда я пытаюсь сделать sudo apt-get update , я получаю несколько ошибок, например:

Failed to fetch blablabla... Cannot initiate the connection to proxy:8080 (proxy). - connect (101: network is unreachable)

В /etc/enviroment у меня есть:

http_proxy="http://proxy:8080/";
https_proxy="https://proxy:8080/";
ftp_proxy="ftp://proxy:8080/";

, когда я делаю $http_proxy , он возвращает http_proxy="http://proxy:8080/";

я установил /etc/gai.conf , чтобы предпочесть IPv4, поставив precedence ::ffff:0:0/96 100

Я использую беспроводную сеть, но у меня есть ethernet. Однако он не распознает Ethernet. Установки запросили прокси-сервер, и он принял его (не уверен, использовал ли он его или нет).

edit: route -n дает:

Kernel IP routing table
Destination     Gateway     Genmask     Flags Metric Ref     Use Iface
    
задан user3603528 10.02.2015 в 14:55
источник

3 ответа

1

Я думаю, вам может понадобиться установить прокси-сервер специально для apt, см. эту ссылку документации ubuntu , который является источником для следующего:

Setting up apt-get to use a http-proxy

These are three methods of using apt-get with a http-proxy.

Temporary proxy session

This is a temporary method that you can manually use each time you want to use apt-get through a http-proxy. This method is useful if you only want to temporarily use a http-proxy.

Enter this line in the terminal prior to using apt-get (substitute your details for your proxy address and proxy port):>

export http_proxy=http://yourproxyaddress:proxyport

If you normally use sudo to run apt-get you will need to login as root first for this to work unless you also add some explicit environment settings to /etc/sudoers, e.g.

Defaults env_keep = "http_proxy https_proxy ftp_proxy"

APT configuration file method

This method uses the apt.conf file which is found in your /etc/apt/ directory. This method is useful if you only want apt-get (and not other applications) to use a http-proxy permanently.

On some installations there will be no apt-conf file set up. This procedure will either edit an existing apt-conf file or create a new apt-conf file.

Add this line to your /etc/apt/apt.conf file (substitute your details for your proxy address and proxy port).

Acquire::http::Proxy "http://yourproxyaddress:proxyport";

Save the apt.conf file.

BASH rc method

This method adds a two lines to your .bashrc file in your $HOME directory. This method is useful if you would like apt-get and other applications for instance wget, to use a http-proxy.

Add these lines to the bottom of your ~/.bashrc file (substitute your details for your proxy address and proxy port)

http_proxy=http://yourproxyaddress:proxyport export http_proxy

Save the file. Close your terminal window and then open another terminal window or source the ~/.bashrc file:

source ~/.bashrc Test your proxy with sudo apt-get update and whatever networking tool you desire. You can use firestarter or conky to see active connections.

If you make a mistake and go back to edit the file again, you can close the terminal and reopen it or you can source ~/.bashrc as shown above.

source ~/.bashrc

Then log out and back in and try

apt-get update
    
ответ дан Clive van Hilten 10.02.2015 в 16:37
0

Мне просто нужно было установить это (с Squid) не слишком долго.

Как только у меня была настройка squid, я набрал 'export http_proxy = 0.0.0.0: 3128 & amp; & amp; & amp; export https_proxy = 0.0.0.0: 3128 ", где 0.0.0.0 - IP-адрес прокси-сервера, а 3128 - номер порта (номер по умолчанию для squid).

Посмотрите, работает ли это из командной строки. Затем вы можете добавить его в свой файл ~ / .bashrc, если только вы не хотите, чтобы прокси-сервер был доступен для всех пользователей.

    
ответ дан Verron Knowles 10.02.2015 в 15:27
0

У меня была проблема, которая была несколько схожа. Недавно я установил скрипач , и мои браузеры отлично работали, прежде чем устанавливать его.

Моя ОС - Ubuntu 16.04 LTS, а браузеры Im используют Google Chrome и Mozilla firefox.

После перезагрузки я понял, что ни один браузер не работает или не подключается к Интернету. Все они отображали

the proxy server is refusing connections

Затем я вспомнил, что я установил скрипач и просто открыл его снова, чтобы снова работать в браузерах.

    
ответ дан Ebrahim Karam 29.06.2016 в 17:09