Контроль яркости экрана не работает на Lenovo T530

7

Мой контроль яркости не работает со свежей установкой 12.10 (новый ноутбук). Он настроен на самую яркую настройку при загрузке, и когда я пытаюсь изменить его, я вижу, что панель уведомлений появляется, но яркость на самом деле не меняется. Я пробовал все решения, которые я мог найти в Интернете, но никто из них не работает. Вещи, которые я пробовал, включают:

Editing /sys/class/backlight/acpi_video0/brightness

In /usr/share/X11/xorg.conf.d/10-brightness-control.conf: Option "RegistryDwords" "EnableBrightnessControl=1"

In /etc/default/grub: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

В 12.10 нет файла xorg.conf, который я нашел, поэтому решения, предлагающие редактировать этот файл, не приносят мне много пользы.

В настоящее время я использую драйвер Nouveau, но переход на проприетарные драйверы Nvidia не имеет никакого значения.

Любые другие идеи? Когда эта ошибка будет исправлена? Со всеми отчетами, которые я встретил, я думаю, что это привлечет много внимания. Спасибо.

    
задан Matt 28.11.2012 в 02:57
источник

4 ответа

6

У меня была аналогичная проблема на моем Thinkpad W530. Наконец, я нашел решение:

Ссылка

These days X automatically configures itself, so you can't just edit the xorg.conf file, you instead need to add a section to a file in /usr/share/X11/xorg.conf.d/ and X will include that section in the configuration that it automatically generates.

So to get the screen brightness keys working with your Nvidia graphics card, create a file in the xorg.conf.d directory, e.g:

sudo gedit /usr/share/X11/xorg.conf.d/10-nvidia-brightness.conf

Paste the following into the file:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro K1000M"
    Option         "RegistryDwords" "EnableBrightnessControl=1"
EndSection
    
ответ дан phewner 27.11.2013 в 05:36
источник
1

Удалили ли Ubuntu патчи с ядра с 3.7 до 3.6? Это может быть причиной, см. Здесь: Ссылка

Попробуйте использовать ползунок яркости vom «Системные настройки» > «Яркость и блокировка» в GNOME.

    
ответ дан Peter Weber 02.12.2012 в 17:02
0

Обновлен ли grub ( sudo update grub ) после редактирования /etc/default/grub и перезагрузки?

Если выше не работает Также попробуйте только acpi_backlight=vendor .

Если это параметр thinkpad thinkpad-acpi.brightness_enable=1 , также требуется.

Вы можете проверить, использует ли ваша система драйвер thinkpad-acpi, используя следующую команду:

lsmod | grep thinkpad_acpi

Отметьте эту страницу (см. первый абзац и методы диагностики)

Обновление:

Еще одна вещь, которую я просто показываю, вы отредактировали файл /etc/X11/xorg.conf ? в вашем вопросе вы указываете на другое место, о котором я никогда не слышал. Выполнить nvidia-xconfig для создания файла конфигурации, если /etc/X11/xorg.conf не существует.

Во-вторых, попробуйте одно решение за один раз. если это не работает, вернитесь назад и перезагрузитесь, затем попробуйте другое решение.

Другим обходным решением может быть

Попробуйте указать пути, показанные ls /sys/class/backlight/*/brightness , и замените их соответствующим образом.

Примеры путей будут выглядеть как

/sys/class/backlight/acpi_video0/brightness
  1. Для вышеуказанного пути. Получите максимальную яркость:

cat /sys/class/backlight/acpi_video0/max_brightness

Попробуйте более низкое значение для установки яркости, например, выход 16, поэтому я попытаюсь с половиной этого

echo 8 | sudo tee /sys/class/backlight/acpi_video0/brightness

Если это работает , сделайте это автоматически при каждом входе в систему, выполнив следующие

sudo gedit /etc/rc.local

Введите эту строку непосредственно перед exit 0 . Он должен выглядеть как

echo YOUR_VALUE_HERE > /sys/class/backlight/acpi_video0/brightness
exit 0

Также вы можете попробовать xdotool

    
ответ дан Web-E 28.11.2012 в 04:58
0

Это своего рода workaroun, но вы можете попробовать установить яркость через командную строку, используя:

xbacklight -set 100

Если это работает, попробуйте привязать глобальную комбинацию клавиш к

xbacklight -inc 5

и

xbacklight -dec 5
    
ответ дан rzymek 12.08.2016 в 13:50