Невозможно использовать быстрые клавиши IntelliJ IDEA на Ubuntu

118

Я очень новичок в Ubuntu, и у меня возникла проблема, когда я не знаю, как это сделать. Я даже попытался найти его в Интернете для ответов, но, возможно, я не знаю правильных условий для его поиска.

Я работаю с IntelliJ IDEA , приложением для разработки. И я очень привык к быстрым клавишам, но когда я перешел с Windows XP на Ubuntu 13.10, некоторые ярлыки больше не работают. Например, например:

  • Ctrl + Alt + < (стрелка влево)
  • Alt + F8

Есть ли причина, почему? и есть ли какое-либо исправление для этого? Или, может быть, просто что-то, что поможет мне в поиске.

Спасибо всем заблаговременно.

    
задан Rodrigo Sasaki 28.01.2014 в 12:01
источник

10 ответов

190

Как немного чтения научил меня, что Intellij IDEA - ориентированная на клавиатуру IDE. Это означает, что использование может работать с ним без необходимости касаться мыши. Также я управляю установкой раскладки клавиатуры.

Для Ubuntu

См. как сменить ярлыки клавиш?

Ниже приведен список настроек, которые необходимо выполнить с привязками системных ключей по умолчанию, чтобы они не мешали действиям IntelliJ IDEA (перечисленные в скобках).

  • Disable the Shade window action, assigned to Ctrl + Alt + S (Settings dialog)
  • Change or disable the Lock Screen action, assigned to Ctrl + Alt + L (Reformat code)
  • Change or disable the Launch terminal action, assigned to Ctrl + Alt + T (Surround with)
  • Change or disable the Switch to workspace action, assigned to Ctrl + Alt + Arrow Keys (Navigation)
  • Disable the Move window action, assigned to Alt + F7 (Find usages)
  • Change or disable the Resize window action, assigned to Alt + F8 (Evaluate expression)

Надеюсь, это поможет!

Примечание. Вы всегда можете вернуть ярлыки Ubuntu обратно в состояние по умолчанию. Просто обратитесь к Как восстановить стандартные сочетания клавиш по умолчанию? , если вы потеряны .

Источник: - Intellij IDEA Keymap

    
ответ дан AzkerM 28.01.2014 в 12:39
источник
28

Я столкнулся с этой проблемой, но мое решение было иным.

Не требуется взломать или изменить системную раскладку по всей системе

IntelliJ имеет разные Keymaps, которые вы можете изменить в соответствии с вашей ОС.

Из настроек вы можете изменить IntelliJ Keymap .

Просто перейдите к Settings -> Keymap и выберите нужную раскладку в раскрывающемся списке. В моем случае я выбрал «Default for GNOME», так как я использую Ubuntu Gnome 16.04.

    
ответ дан Francisco C. 25.06.2016 в 05:18
15

Для ubuntu 18.04 LTS ctrl + alt + left (Контекст ярлыка идеи Intellij)

  • установить редактор Dconf в программном обеспечении ubuntu
  • запустите редактор Dconf, перейдите к / org / gnome / desktop / wm / keybindings / switch-to-workspace-left

  • двойной щелчок, как показано ниже

  • используйте значение по умолчанию (нажмите «Выкл.») - > Пользовательское значение (например, я или нет)

  • вы могли бы использовать его в intellij idea now

    
ответ дан think 06.05.2018 в 09:42
5

Я создал этот скрипт, который отключает все сочетания ярлыков между Ubuntu (тестируется с 15.10) и IntelliJ (и, вероятно, больше продуктов Jetbrains). Он отключает их в Ubuntu.

Он также создает файл резервной копии, чтобы восстановить предыдущие настройки.

Чтобы отключить некоторые ярлыки, прокомментируйте их в массиве KEYS .

#!/bin/bash
set -euo pipefail

# Disables Ubuntu shortcuts that clash with IntelliJ Idea (and probably other
# Jetbrain products).
#
# Creates a backup file to restore the previous settings. To not have some
# shortcuts disabled, comment them out in the 'KEYS' array.
#
# Tested on : Ubuntu 15.10
# Author    : Jonas Gröger

readonly BACKUP_FILE="undo-fix-shortcuts-$(date +%s%N).sh"
readonly KEYS=(
    "/org/gnome/desktop/wm/keybindings/toggle-shaded"
    "/org/gnome/settings-daemon/plugins/media-keys/screensaver"
    "/org/gnome/settings-daemon/plugins/media-keys/terminal"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-down"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-up"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-left"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-right"
    "/org/gnome/desktop/wm/keybindings/begin-move"
    "/org/gnome/desktop/wm/keybindings/begin-resize"
    # To disable resetting a value, just comment out the line
)
readonly DISABLED_VALUE="['disabled']"

main() {
    # Make backup
    printf "#!/bin/bash\n" >>  "$BACKUP_FILE"
    for key in "${KEYS[@]}"; do
        local value
        value=$(dconf read "$key")
        printf "dconf write \"%s\" \"%s\"\n" "$key" "$value" >> "$BACKUP_FILE"
    done

    # Disable all Ubuntu shortcuts
    for key in "${KEYS[@]}"; do
        dconf write "$key" "$DISABLED_VALUE"
    done
}
main

Вы можете получить это отсюда:

wget -O fix-shortcuts.sh https://gist.githubusercontent.com/JonasGroeger/94cfa1071fa12572f465/raw/fix-shortcuts.sh
    
ответ дан Jonas Gröger 16.12.2015 в 21:40
3

Смотрите здесь , чтобы использовать программные коды Ubuntu программно, и только если окна определенных приложений активны.

В частности, используйте эти значения (при условии, что вы используете JetBrains Toolbox со стандартным путем установки, в противном случае измените):

apppattern = "JetBrains"
backupfile = "~/.local/share/JetBrains/keymap_backup"

Пока выполняется скрипт, ярлыки Ubuntu всегда будут работать, кроме случаев, когда IDEA и др. имеют фокус.

У меня есть набор ярлыков, специфичных для JetBrains здесь ; вход оценивается.

    
ответ дан Raphael 22.12.2016 в 13:32
2

Просто чтобы немного расширить превосходный ответ AzkerM:

  • Disable the Move window action, assigned to Alt + F7 (Find usages)
    • from Settings --> Keyboard --> Shortcuts --> Windows --> Move Window
  •   
  • Измените или отключите действие окна Resize, присвоенное Alt + F8 (выражение Evaluate)      
    • from Settings --> Keyboard --> Shortcuts --> Windows --> Resize Window
  •   
    
ответ дан WillC 24.02.2016 в 11:15
1

Я запускаю Ubuntu 16.04, и что происходит, когда я использовал эти ключевые штрихи (ctrl-alt-left / right), окно менялось и помещалось вправо или влево от моего экрана. Я попытался отключить эти привязки клавиш в: Настройки / Клавиатура / Навигация, хотя у меня нет рабочих областей. Это все еще не мешало моему поведению.

К счастью, я открыл Compiz и наткнулся на плагин Window Management / Grid, который сопоставлял эти ключи, чтобы поместить окна в позицию сетки. Я отключил этот плагин, и теперь мои быстрые клавиши IntelliJ работают нормально с помощью ctrl-alt-left / right.

    
ответ дан Jason White 13.06.2016 в 22:08
1

Просто быстрый способ обхода:
Если на клавиатуре имеется клавиша « Windows ", вы можете просто добавить его во всю комбинацию ярлыков - он должен работать. Например:

  • Ctrl + Win + Alt + T (Surround with)
  • Win + Alt + F8 (Вычислить выражение )
ответ дан guzoff 28.11.2017 в 20:53
0

Я использую Xneur для переключения туманного текста на другой язык. Моя система langauge обрабатывается Ctrl + Shift , что блокирует горячие клавиши Intellij , например Ctrl + Shift + F (глобальный поиск) и Ctrl + Shift + C (комментарий). Поэтому левый сдвиг игнорируется.

  • Одним из решений является изменение языка с использованием Ctrl_L + Shift_L и использования Ctrl_R + Shift_R для Intellij . Но это какой-то дискомфорт.

  • Другим решением является использование Xneur ( sudo ap-get install xneur ) для Повторить неверный текст на другом языке. Вы можете отключить любую переключение системы и назначить ее горячим клавишам xneur (тот же Ctrl+Shift ). Xneur можно добавить в автозапущенные приложения.

ответ дан Zon 04.09.2018 в 05:28
0

Для Ubuntu 16.04 перейдите в настройки > Клавиатура и найдите конкретную комбинацию, противоречащую вашему желаемому клику, и обновите ее до новой.

    
ответ дан Cengkuru Michael 29.10.2017 в 09:22

Ознакомьтесь с другими вопросами по меткам