Ubuntu на Acer E5 573G-71L9 - беспроводная локальная сеть отключается случайно

0

Я уже задал этот вопрос в сообществе Acer - если кто-то ответит туда, я поделюсь решением. Но, надеюсь, кто-то здесь будет еще быстрее.

Как упоминалось в другом потоке, я наконец получил Ubuntu 15.10, установленный на моем E5 573G-71L9. Сначала беспроводная локальная сеть не работала, но мне удалось найти и установить предположительно правильные драйверы.

Что я сделал: сначала убедитесь, что у меня был правильный драйвер r8168 для карты Realtek, загруженный с сайта Realtek.

Как Wi-Fi все еще не работает, я также понял, что именно карта Atheros нуждается в правильном драйвере. Я следовал этому методу (я просто просто скопировал - вставлял все команды, не понимая их полностью): Устройство Qualcomm Atheros [168c: 0042] (версия 30) Установка драйвера Wi-Fi

Это привело к тому, что мое беспроводное соединение стало жить, но я часто отключился, примерно каждые две минуты. По словам менеджера сети, я все еще подключен, но я не могу даже пинговать DNS-сервер (я могу ping localhost). Иногда соединение восстанавливается через некоторое время, иногда мне нужно "отключиться" и снова подключиться.

Кроме того, я очистил драйвер r8168, который я загрузил с Acer, и установил r8168 из Ubuntu Software Center - без разницы. Я также заменил драйвер Atheros тем, который решил проблему для человека с той же конфигурацией системы (см. Другой поток). Для меня это не сработало.

Мой regdomain настроен на Германию (где я живу). Я попытался отключить аппаратное шифрование (nohwcrypt = 0) и различные другие параметры для iwlwifi, которые были предложены на нескольких форумах и на askubuntu, которые я больше не помню (ничего не работало, поэтому я удалил их все из / etc / modprobe .d / files, поэтому они должны быть "чистыми" снова.

Проводной интернет работает без проблем.

dmesg | grep ath10k

[   12.529816] ath10k_pci 0000:03:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
[   12.835697] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/cal-pci-0000:03:00.0.bin failed with error -2
[   13.299474] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/board-2.bin failed with error -2
[   15.171270] ath10k_pci 0000:03:00.0: qca9377 hw1.0 (0x05020000, 0x003820ff sub 11ad:0806) fw WLAN.TF.1.0-00267-1 fwapi 5 bdapi 1 htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 features ignore-otp
[   15.171273] ath10k_pci 0000:03:00.0: debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
[   15.228201] ath10k_pci 0000:03:00.0 wlp3s0: renamed from wlan0

С отключенным кабелем Ethernet я выполнил сценарий беспроводной информации, как это предусмотрено в Ubuntuforums. Поскольку файл слишком большой для копирования здесь, а вложения не разрешены, я помещаю вывод в мою общедоступную папку Dropbox: Ссылка

Буду благодарен за любые указатели в правильном направлении. Спасибо!

    
задан Eelco Herder 09.01.2016 в 21:16
источник

2 ответа

1

Наконец, я нашел решение этой проблемы. Вернее, решение было реализовано для меня: необходимые драйверы теперь являются частью дистрибутива Ubuntu 16.10. Это работает из коробки: -).

    
ответ дан Eelco Herder 26.02.2017 в 23:44
0

Если вы можете переименовать SSID беспроводных маршрутизаторов, я бы изменил его на имя без пробелов. Сделайте Kristof&Eelco и измените канал с авто на канал 6. Перезагрузите маршрутизатор и проверьте

    
ответ дан Jeremy31 11.01.2016 в 23:20