apt-get установить «maven» или «maven3»

7

Мне нужно уточнить, как установить последнюю версию maven. Когда я запускаю эту команду на новом серверном компьютере Ubuntu 16.04 (я еще не установил maven), я получаю следующее сообщение:

[email protected]:~$ mvn
The program 'mvn' is currently not installed. You can install it by typing:
sudo apt install maven

Но я вижу другие сообщения на форуме, говорящие, чтобы установить «maven3». Поэтому мой вопрос в том, в чем разница между apt-get install «maven» и «maven3»? «Maven» устанавливает более старую версию, или это просто указывает на любую последнюю версию? Должен ли я просто использовать «maven3» вместо?

Если это помогает, я пишу этот скрипт для настройки новой рабочей станции разработчика на Ubuntu 16.04, начиная с нуля.

    
задан Ross 07.05.2016 в 16:38
источник

1 ответ

6

apt-cache show maven | grep Version для меня показывает

Version: 3.0.5-1

, поэтому пакет maven является достаточно последней версией maven 3.x.x.

apt-cache show maven3 для меня дает

N: Unable to locate package maven3
E: No packages found

, поэтому попытка установить maven3 , вероятно, завершится неудачей, если у вас нет нестандартного набора репозиториев в списке поиска.

Также см. Ссылка

    
ответ дан Mike Samuel 11.08.2016 в 15:14
источник