Драйвер для Canon LBP 2900

7

Как установить драйвер для принтера Canon LBP 2900 в Ubuntu 14.04?

Я попытался установить драйверы из официальной поддержки CANON и проверил другие ответы на Ask Ubuntu, но пока никаких результатов.

    
задан user275919 29.04.2014 в 17:44
источник

3 ответа

3

Ниже мое рабочее решение, адаптируемое для других моделей LBP и amp; Битовые скорости ПК.

Установка

В случае 64-битного Ubuntu принтер Canon LBP2900:

git clone https://github.com/hugolpz/Canon_printer.git
cd ./Canon_printer
make -f ./download.mk
sudo make -f ./install.mk BITS=64 PRINTER=LBP2900
sudo make -f ./OS_restart.mk
sudo make -f ./install.mk BITS=64 PRINTER=LBP2900

Адаптируйте к своей битовой ширине.

Перезагрузка ОС

Если принтер не работает после установки & amp; Перезапуск ОС:

sudo pkill -9 -x ccpd
sudo /etc/init.d/ccpd start   # Output should have 2 numbers of 4 digits !
> Canon Printer Daemon for CUPS: ccpd: 2626 2615    # seems good :)

Дополнительные инструкции см. в разделе Ссылка

Рекомендации

Купите не совместимый с Canon Linux принтер.

    
ответ дан Hugolpz 04.01.2015 в 12:20
1

Это последний драйвер из канона. Его версия 2.60, и вы можете скачать его здесь .

После извлечения он будет иметь как 32-битные драйверы, так и 64-битные драйверы.

Это программное обеспечение является драйвером принтера CAPT, который обеспечивает функции печати для принтеров Canon LBP, работающих в среде CUPS (Common UNIX Printing System), системы печати, которая работает в операционных системах Linux.     

ответ дан Mitch 29.04.2014 в 17:52
1

Это сработало для меня в Linux Mint 17 32-bit (более или менее Ubuntu 14.04 32-bit).

  1. Загрузите и установите драйверы.

    Перейдите на веб-сайт Canon Asia (или любой другой веб-сайт Canon) и загрузите драйвер принтера CAPT для Linux версии 2.60 из эту ссылку .

    Извлеките его, чтобы получить папку, содержащую каталог 32-bit_Driver / Debian, введите внутри.

    Установите файл .deb cndrvcups-common_2.60-1_i386.deb из терминала:

    sudo dpkg -i cndrvcups-common_2.60-1_i386.deb
    

    Вы также можете установить его с помощью установщика пакетов gdebi.

    Далее установите cndrvcups-capt_2.60-1_i386.deb

    sudo dpkg -i cndrvcups-capt_2.60-1_i386.deb
    
  2. Установите другие шрифты postscript и программу для резервирования портов для принтера.

    Установите portreserve, gsfonts, gsfonts-other, gsfonts-X11 через диспетчер пакетов Synaptic.

  3. Перезагрузите принтер.

    service cups restart
    
  4. Добавьте принтер и запустите демон принтера Canon.

    sudo /usr/sbin/lpadmin -p LBP2900 -m CNCUPSLBP2900CAPTK.ppd -v ccp://localhost:59787 -E  
    sudo /usr/sbin/ccpdadmin -p LBP2900 -o /dev/usb/lp0
    sudo service ccpd start
    sudo service ccpd status
    
  5. Проверьте состояние принтера.

    captstatusui -P LBP2900
    

    Если вы видите сообщение Ready to print , все готово! Возможно, вам придется перезапустить систему и повторить все шаги с шага 4.

    Он может перестать работать после перезапуска системы. Запустите sudo service ccpd restart и повторите попытку.

ответ дан Vishnu Namboothiri K 09.06.2014 в 04:37