Плохая производительность графики из-за неправильных настроек mtrr

7

Я использую последнее ядро ​​на Dell LAtitude E4310 с оперативной памятью 8 Гбайт

2.6.38-10-generic #44-Ubuntu SMP Thu Jun 2 21:32:22 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

При загрузке я получаю следующее сообщение

[drm] MTRR allocation failed.  Graphics performance may suffer.

, и действительно мой /proc/mtrr выглядит странно

reg00: base=0x000000000 (    0MB), size= 8192MB, count=1: write-back
reg01: base=0x200000000 ( 8192MB), size=  512MB, count=1: write-back
reg02: base=0x0e0000000 ( 3584MB), size=  512MB, count=1: uncachable
reg03: base=0x0dc000000 ( 3520MB), size=   64MB, count=1: uncachable
reg04: base=0x0db400000 ( 3508MB), size=    4MB, count=1: uncachable
reg05: base=0x21c000000 ( 8640MB), size=   64MB, count=1: uncachable

Я пробовал mtrr-uncover , но он не работает:

./mtrr-uncover 
Initial MTRR configuration:
 0  0x000000000-0x1ffffffff write-back
         4  0x0db400000-0x0db7fffff uncachable
         3  0x0dc000000-0x0dfffffff uncachable
         2  0x0e0000000-0x0ffffffff uncachable
 1  0x200000000-0x21fffffff write-back
         5  0x21c000000-0x21fffffff uncachable
./mtrr-uncover: 9 MTRRs needed but only 8 in architecture.

Кто-нибудь знает, как правильно установить mtrr в моей архитектуре?

здесь соответствующий выход lspci -v

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
    Subsystem: Dell Device 0410
    Flags: bus master, fast devsel, latency 0, IRQ 42
    Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 60b0 [size=8]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915
    
задан elforma 11.06.2011 в 21:47
источник

1 ответ

5

Для этого есть простое решение. Просто используйте параметр загрузки ядра enable_mtrr_cleanup .

Изменить файл конфигурации /etc/default/grub :

$ sudo nano /etc/default/grub

найдите строку, содержащую GRUB_CMDLINE_LINUX_DEFAULT , и вы, вероятно, увидите эти параметры по умолчанию:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Итак, чтобы использовать enable_mtrr_cleanup , вы добавите его так:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash enable_mtrr_cleanup"

Затем вы должны обновить конфигурацию grub с помощью этой команды:

$ sudo update-grub2

И перезагрузка:

$ sudo reboot

Тогда сообщение исчезнет, ​​и вы увидите, что система нашла правильные значения для MTRR.

    
ответ дан k23 23.09.2011 в 22:09