«SIOCSIFFLAGS: операция невозможна из-за RF-kill»?

48

Я получаю эту ошибку как часть этой проблемы здесь , но так как эта проблема совершенно другая проблема, я думаю, что лучше рассмотреть эту проблему отдельно. Мой wlan0 не работает. Когда я пытаюсь включить его с помощью

$  sudo ifconfig wlan0 up

SIOCSIFFLAGS: Operation not possible due to RF-kill

, а затем

$ sudo rfkill list all

0: phy0: Wireless LAN 

     Soft blocked: yes

     Hard blocked: no

1: tpacpi_bluetooth_sw: Bluetooth

     Soft blocked: yes

     Hard blocked: yes

Что означает сообщение msg? Что такое RF-kill?

Спецификации оборудования

  $ sudo lshw -class network
  *-network
       description: Ethernet interface
       product: 82573L Gigabit Ethernet Controller
       vendor: Intel Corporation
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: eth0
       version: 00
       serial: 00:16:d3:22:96:c2
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=1.2.20-k2 firmware=0.5-1 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:44 memory:ee000000-ee01ffff ioport:2000(size=32)
  *-network DISABLED
       description: Wireless interface
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: [email protected]:03:00.0
       logical name: wlan0
       version: 02
       serial: 00:13:02:46:63:74
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 driverversion=2.6.38-11-generic firmware=15.32.2.9 latency=0 link=no multicast=yes wireless=IEEE 802.11abg
       resources: irq:45 memory:edf00000-edf00fff

Версия ОС и версия ядра

$ cat /etc/lsb-release 
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"
$ uname -r
2.6.38-11-generic

[Обновление]

Когда я применяю предложение Fossfreedom, я получаю "SIOCSIFFLAGS: No such device" . Ядро почему-то отклоняет карту, как указано FF.

Dmesg после отключения и включения wli3945 с заблокированным WiFi

# modprobe -r iwl3945
# modprobe iwl3945
# dmesg|tail -n 50
[ 6835.430537] PM: resume of devices complete after 1889.701 msecs
[ 6835.430800] PM: resume devices took 1.888 seconds
[ 6835.430845] PM: Finishing wakeup.
[ 6835.430847] Restarting tasks ... done.
[ 6835.502666] video LNXVIDEO:00: Restoring backlight state
[ 6835.572203] [drm:drm_mode_getfb] *ERROR* invalid framebuffer id
[ 6835.852380] e1000e 0000:02:00.0: irq 46 for MSI/MSI-X
[ 6835.908162] e1000e 0000:02:00.0: irq 46 for MSI/MSI-X
[ 6835.908775] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 6836.919274] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=600
[ 6837.769253] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=600
[ 6859.097311] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
[ 6882.076501] e1000e 0000:02:00.0: irq 46 for MSI/MSI-X
[ 6882.132190] e1000e 0000:02:00.0: irq 46 for MSI/MSI-X
[ 6882.132924] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 6883.722633] e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: Rx/Tx
[ 6883.722645] e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO
[ 6883.723071] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 6894.000044] eth0: no IPv6 routers present
[ 6896.551932] exe (2743): /proc/2743/oom_adj is deprecated, please use /proc/2743/oom_score_adj instead.
[ 8289.212078] usb 1-2: new high speed USB device using ehci_hcd and address 4
[ 8289.280270] hub 1-0:1.0: unable to enumerate USB device on port 2
[ 8289.608059] usb 1-2: new high speed USB device using ehci_hcd and address 5
[ 8291.006963] usb 1-2: USB disconnect, address 5
[ 8291.308072] usb 1-2: new high speed USB device using ehci_hcd and address 6
[ 8291.591228] usb 1-2: USB disconnect, address 6
[ 9598.556083] usb 1-2: new high speed USB device using ehci_hcd and address 7
[ 9599.059441] usb 1-2: USB disconnect, address 7
[11838.072332] iwl3945 0000:03:00.0: Master Disable Timed Out, 100 usec
[11838.072993] iwl3945 0000:03:00.0: PCI INT A disabled
[11850.210319] cfg80211: Calling CRDA to update world regulatory domain
[11850.218431] cfg80211: World regulatory domain updated:
[11850.218436] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[11850.218440] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[11850.218444] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[11850.218448] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[11850.218452] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[11850.218456] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[11850.291510] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
[11850.291515] iwl3945: Copyright(c) 2003-2010 Intel Corporation
[11850.291601] iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[11850.291624] iwl3945 0000:03:00.0: setting latency timer to 64
[11850.331841] iwl3945 0000:03:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[11850.331847] iwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945ABG
[11850.332023] iwl3945 0000:03:00.0: irq 45 for MSI/MSI-X
[11850.332274] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain 
[11850.332436] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
[11850.361710] iwl3945 0000:03:00.0: loaded firmware version 15.32.2.9
[11850.361885] iwl3945 0000:03:00.0: Radio disabled by HW RF Kill switch
[11850.365924] iwl3945 0000:03:00.0: Radio disabled by HW RF Kill switch

Dmesg с разблокированным WiFi

# rfkill list all
1: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: no
    Hard blocked: yes
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
# dmesg|tail -n 50
[   27.649606] fb0: inteldrmfb frame buffer device
[   27.649608] drm: registered panic notifier
[   27.649815] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[   27.662754] HDA Intel 0000:00:1b.0: PCI INT B -> GSI 17 (level, low) -> IRQ 17
[   27.662760] hda_intel: probe_mask set to 0x1 for device 17aa:2010
[   27.662831] HDA Intel 0000:00:1b.0: irq 46 for MSI/MSI-X
[   27.662868] HDA Intel 0000:00:1b.0: setting latency timer to 64
[   27.769460] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x100-0x3af: excluding 0x170-0x177 0x1f0-0x1f7 0x2f8-0x2ff 0x370-0x377
[   27.774801] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x3e0-0x4ff: excluding 0x3f0-0x3f7 0x4d0-0x4d7
[   27.775742] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x820-0x8ff: clean.
[   27.788575] pcmcia_socket pcmcia_socket0: cs: IO port probe 0xc00-0xcf7: clean.
[   27.789382] pcmcia_socket pcmcia_socket0: cs: memory probe 0x0c0000-0x0fffff: excluding 0xc0000-0xd3fff 0xdc000-0xfffff
[   27.789466] pcmcia_socket pcmcia_socket0: cs: memory probe 0xa0000000-0xa0ffffff: clean.
[   27.789547] pcmcia_socket pcmcia_socket0: cs: memory probe 0x60000000-0x60ffffff: excluding 0x60000000-0x60ffffff
[   27.789632] pcmcia_socket pcmcia_socket0: cs: IO port probe 0xa00-0xaff: clean.
[   27.813146] e1000e 0000:02:00.0: irq 44 for MSI/MSI-X
[   27.868221] e1000e 0000:02:00.0: irq 44 for MSI/MSI-X
[   27.868866] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   27.876620] IBM TrackPoint firmware: 0x0e, buttons: 3/3
[   27.892982] input: TPPS/2 IBM TrackPoint as /devices/platform/i8042/serio1/input/input6
[   28.121555] ppdev: user-space parallel port driver
[   29.426589] e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: Rx/Tx
[   29.426597] e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO
[   29.426893] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   31.009483] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
[   34.474875] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
[   40.160038] eth0: no IPv6 routers present
[ 7394.332227] exe (1666): /proc/1666/oom_adj is deprecated, please use /proc/1666/oom_score_adj instead.
[ 7587.420396] iwl3945 0000:03:00.0: PCI INT A disabled
[ 7599.728554] cfg80211: Calling CRDA to update world regulatory domain
[ 7599.736628] cfg80211: World regulatory domain updated:
[ 7599.736632] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 7599.736637] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 7599.736641] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 7599.736645] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 7599.736649] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 7599.736653] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 7599.797314] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
[ 7599.797319] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[ 7599.797397] iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 7599.797419] iwl3945 0000:03:00.0: setting latency timer to 64
[ 7599.837714] iwl3945 0000:03:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 7599.837719] iwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 7599.837880] iwl3945 0000:03:00.0: irq 45 for MSI/MSI-X
[ 7599.838124] Registered led device: phy0-led
[ 7599.838170] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain 
[ 7599.838335] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
[ 7599.980440] iwl3945 0000:03:00.0: loaded firmware version 15.32.2.9
[ 7599.980656] iwl3945 0000:03:00.0: Radio disabled by HW RF Kill switch
[ 7599.983562] iwl3945 0000:03:00.0: Radio disabled by HW RF Kill switch

Dmesg и Iwl3945 без заблокированного Wi-Fi

# modprobe -r iwl3945
# modprobe iwl3945
# dmesg| tail -n 50
[   29.426597] e1000e 0000:02:00.0: eth0: 10/100 speed: disabling TSO
[   29.426893] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   31.009483] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
[   34.474875] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
[   40.160038] eth0: no IPv6 routers present
[ 7394.332227] exe (1666): /proc/1666/oom_adj is deprecated, please use /proc/1666/oom_score_adj instead.
[ 7587.420396] iwl3945 0000:03:00.0: PCI INT A disabled
[ 7599.728554] cfg80211: Calling CRDA to update world regulatory domain
[ 7599.736628] cfg80211: World regulatory domain updated:
[ 7599.736632] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 7599.736637] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 7599.736641] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 7599.736645] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 7599.736649] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 7599.736653] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 7599.797314] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
[ 7599.797319] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[ 7599.797397] iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 7599.797419] iwl3945 0000:03:00.0: setting latency timer to 64
[ 7599.837714] iwl3945 0000:03:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 7599.837719] iwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 7599.837880] iwl3945 0000:03:00.0: irq 45 for MSI/MSI-X
[ 7599.838124] Registered led device: phy0-led
[ 7599.838170] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain 
[ 7599.838335] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
[ 7599.980440] iwl3945 0000:03:00.0: loaded firmware version 15.32.2.9
[ 7599.980656] iwl3945 0000:03:00.0: Radio disabled by HW RF Kill switch
[ 7599.983562] iwl3945 0000:03:00.0: Radio disabled by HW RF Kill switch
[ 7906.428550] iwl3945 0000:03:00.0: PCI INT A disabled
[ 7913.242835] cfg80211: Calling CRDA to update world regulatory domain
[ 7913.249969] cfg80211: World regulatory domain updated:
[ 7913.249973] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 7913.249978] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 7913.249982] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 7913.249986] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 7913.249990] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 7913.249994] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 7913.311805] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
[ 7913.311810] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[ 7913.311885] iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 7913.311907] iwl3945 0000:03:00.0: setting latency timer to 64
[ 7913.352172] iwl3945 0000:03:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 7913.352177] iwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 7913.352330] iwl3945 0000:03:00.0: irq 45 for MSI/MSI-X
[ 7913.352601] Registered led device: phy0-led
[ 7913.352642] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain 
[ 7913.352806] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
[ 7913.385208] iwl3945 0000:03:00.0: loaded firmware version 15.32.2.9
[ 7913.385384] iwl3945 0000:03:00.0: Radio disabled by HW RF Kill switch
[ 7913.387138] iwl3945 0000:03:00.0: Radio disabled by HW RF Kill switch
    
задан Community 19.09.2011 в 22:27
источник

9 ответов

42

Soft-блокировочные

Вывод на sudo rfkill list показывает, что ваша сетевая карта «мягко заблокирована».

Это может произойти, когда беспроводная карта будет сигнализирована о выключении через ядро.

Попробуйте выполнить следующие действия:

  1. выполняется в терминале:

    sudo rfkill unblock wifi; sudo rfkill unblock all

  2. rerun sudo rfkill list , чтобы подтвердить, что карта была разблокирована.

  3. перезагрузка

  4. повторно запустите sudo rfkill list , чтобы подтвердить разблокировку, как было сохранено.

  5. rerun sudo lshw -class network - вы должны увидеть, что ядро ​​распознало (или не) беспроводную карту.

Если модуль беспроводного ядра был распознан (он не должен указывать «невостребованный»), Network Manager теперь должен иметь возможность видеть беспроводные сети, доступные в вашей области.

Диагностика проблемы с ядром

Если сетевая карта не распознана - и вы подтвердили, что sudo rfkill list не показывает блокировки (т. е. как мягкие заблокированные, так и заблокированные «нет»), добавьте следующее к вашему вопросу:

sudo modprobe -r iwl3945
sudo modprobe iwl3945
dmesg | tail -n 50

Надеюсь, это укажет на ошибку - например, проблема с прошивкой не загружается.

Загрузка новой прошивки

Если это проблема с прошивкой, вы можете попробовать, возможно, одно из следующих:

  • установить драйверы беспроводной сети backports:

то есть.

sudo apt-get install linux-backports-modules-cw-2.6.39-generic

Затем перезагрузите - проверьте блокировку программного обеспечения и т. д.

  • получите последнюю прошивку следующим образом:

то есть.

wget http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-3945-ucode-15.32.2.9.tgz

tar xzf iwlwifi-3945-ucode-15.32.2.9.tgz

cd iwlwifi-3945-ucode-15.32.2.9

sudo cp iwlwifi-3945-2.ucode /lib/firmware

Затем перезагрузите - проверьте блокировку программного обеспечения и т. д.

N.B. ваша трассировка dmesg должна указывать на то, с чем связано имя прошивки, с которой она связана. Возможно, вам нужно переименовать «iwlwifi-3945-2.ucode» в любое имя прошивки, которое оно ожидало.

    
ответ дан fossfreedom 19.09.2011 в 22:41
источник
4

Убедитесь, что Bluetooth и беспроводные устройства плохо переключаются; убедитесь, что у вас должна быть такая ситуация:

$ sudo rfkill list all
0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Я решил свою проблему:

$sudo rfkill block bluetooth
$sudo rfkill unblock wifi
    
ответ дан alemol 24.07.2013 в 20:21
1

Я подтверждаю эту проблему с ноутбуком Asus X75VD, используя драйвер rt2600pci. Ни одно из приведенных выше предложений не помогло мне, но на французском форуме (1) есть работа, которая действительно работает. Просто приостановите сеанс (закройте крышку) и активируйте его, а Wi-Fi работает.

Я публикую это, потому что другой поток специально для Asus X75VD был помечен как дубликат, и эта модель не имеет физического включения / выключения для Wi-Fi, и последовательность клавиш fn не работает в этом дело.

Он также представляется регрессией, введенной ботом (2)?

Надеюсь, скоро появится патч.

Сэм

  1. Ссылка
  2. Ссылка
ответ дан Nostradamnit 08.05.2013 в 13:38
1

Обходной путь без необходимости приостанавливать сеанс

Имея аналогичный ноутбук Asus, у меня была такая же проблема с Wi-Fi, и я использовал эту временную процедуру для приостановки сеанса, и это довольно надоедливо, чтобы каждый раз ее приостанавливать.

Однако я нашел решение на форумах Fedora , которое также работает в Ubuntu (он, вероятно, работает для любого дистрибутива):

В качестве корня создайте файл с именем asus-wifi.conf в /etc/modprobe.d/ , содержащим:

options asus_nb_wmi wapf=1

После перезагрузки wifi должен быть включен.

    
ответ дан Danijel 20.07.2014 в 08:52
1

У меня была точно такая же проблема с Fujitsu Celsius H250:

14:00.0 Ethernet controller: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 04)
Subsystem: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
Kernel driver in use: ath5k

Это дает мне:

# rfkill list all
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes <--------- !!!
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

В ноутбуке есть 2 слота mini-PCI-e. Один PCI-e (правый) был забит карточкой WiFi, а другой был пуст, я просто переместил карту WiFi в другой (в левый) слот, и все стало хорошо.

Отношения Лаз

    
ответ дан LAZA 01.02.2015 в 13:31
1

Это может или не поможет вам, но я использую компьютер hp, и он говорил то же самое, поэтому то, что я сделал, это моя клавиатура, на нем есть кнопка WiFi, и я просто удерживал ее на секунду и значок вверху исчез и я набрал ifconfig wlan0 up И это сработало

    
ответ дан Julian 06.05.2016 в 07:49
0

отключите ваше жесткое соединение и нажмите клавишу клавиатуры, которая активирует ваше беспроводное устройство. Это то, что решило ту же ошибку для меня.

    
ответ дан nonam35 21.03.2013 в 00:12
0

Для моего ASUS R704V, работающего под управлением Ubuntu 13.10, ни одно из вышеперечисленных предложений не работало. По-видимому, драйверы ядра и аппаратные средства не согласны с тем, что логические уровни «0» и «1» как «заблокированные» и «не заблокированные».

Но я нашел решение странное , которое работает надежно:

  • приостановите работу системы в ОЗУ (либо нажав клавишу SUSPEND, либо используя запись Suspend в меню «Выход» справа от верхней панели)
  • подождите несколько секунд
  • нажмите кнопку питания, чтобы перезагрузить систему.

Весь процесс займет менее 5 секунд.

В результате вывод в список «rfkill list all» показывает

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no

NetworkManager активирует WIFI и должен предлагать точки доступа для подключения.

    
ответ дан asus-user 24.11.2013 в 14:19
-1

Исправление было так же просто, как нажать Fn + F2 , чтобы активировать беспроводную карту для моего ноутбука Dell.

    
ответ дан Roberto rodriguez 23.10.2016 в 03:08