14.04 - 16.04 не удалось; apt (= 1.0.1ubuntu2.13) 'не установлен

48

(Этот вопрос не был разрешен. Из-за временных ограничений компьютер был восстановлен до заводских настроек.)

Я пытался обновить с 14.04 по 16.04, но apt выбрал эту ошибку:

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.

Что это значит и как я могу это исправить?

Когда я набираю команду apt-cache policy apt

[email protected]:~$ apt-cache policy apt apt:
Installed: 1.0.1ubuntu2.11
Candidate: 1.0.1ubuntu2.11
Version table:
*** 1.0.1ubuntu2.11 0
100 /var/lib/dpkg/status
1.0.1ubuntu2 0
500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 
Packages

Ошибка при выполнении команды:

sudo do-release-upgrade -d

и он производит следующее:

Checking for a new Ubuntu release
Get:1 Upgrade tool signature [198 B]
Get:2 Upgrade tool [1,265 kB]
Fetched 1,265 kB in 0s (0 B/s)
authenticate 'xenial.tar.gz' against 'xenial.tar.gz.gpg'
extracting 'xenial.tar.gz'

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done

Required depends is not installed

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.
    
задан Shageenth Sandrakumar 24.05.2016 в 22:45
источник

3 ответа

45

У меня была такая же проблема сегодня. Перед обновлением убедитесь, что ваша версия является последней версией Ubuntu 14.04. (Ubuntu 14.04.4 в это время)

Моя была привязана к Ubuntu 14.04.3 из-за плохого зеркала.

Итак, сначала запустите:

sudo apt update
sudo apt dist-upgrade

Убедитесь, что версия теперь Ubuntu 14.04.4 (обновление сентябрь 2016: Ubuntu 14.04.5 ).

cat /etc/lsb-release

И запустите установку Ubuntu 16.04 с помощью

sudo do-release-upgrade -d
    
ответ дан cnxsoft 25.05.2016 в 08:56
10

Лучше всего обновлять обычные процедуры:

sudo apt update
sudo apt dist-upgrade

Если вышеописанное не выполнено, вы можете вручную выполнить следующее. Этот вопрос устарел, но вы можете просто изменить номера версий, поскольку ссылки все равно должны быть одинаковыми.

Чтобы обновить версию apt в окне терминала, введите следующее:

sudo apt-get download apt

, если вышеуказанное не работает, вы также можете загрузить его с помощью wget , выполнив следующую строку:

wget http://security.ubuntu.com/ubuntu/pool/main/a/apt/apt_1.0.1ubuntu2.13_amd64.deb

затем введите

sudo dpkg -i apt*.deb

Просто попробовал это в моей системе здесь. Вот результат:

[email protected]:~$ sudo apt-get download apt
[sudo] password for terrance: 
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main apt amd64 1.0.1ubuntu2.13 [954 kB]
Fetched 954 kB in 0s (1,127 kB/s)
[email protected]:~$ ls
apt_1.0.1ubuntu2.13_amd64.deb  Documents  examples.desktop  Pictures  Templates
Desktop                        Downloads  Music             Public    Videos
[email protected]:~$ sudo dpkg -i apt*.deb
(Reading database ... 168376 files and directories currently installed.)
Preparing to unpack apt_1.0.1ubuntu2.13_amd64.deb ...
Unpacking apt (1.0.1ubuntu2.13) over (1.0.1ubuntu2.11) ...
Setting up apt (1.0.1ubuntu2.13) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.7) ...

Если после описанных шагов вы видите сбой из-за отсутствия зависимости dpkg, вы можете просто закончить, повторив шаги с помощью dpkg и ...

wget http://security.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg_1.17.5ubuntu5.6_amd64.deb
sudo dpkg -i dpkg_1.17.5ubuntu5.6_amd64.deb

Все пакеты, доступные для Ubuntu, можно найти здесь:

Ссылка

    
ответ дан Terrance 25.05.2016 в 01:02
0

Простое исправление ... Что сработало для меня ...

Откройте ваш менеджер типа пакета «apt» в окне поиска, который покажет вам, что текущая установленная версия apt позволяет предположить, что «1.0.1ubuntu1.13» просто щелкните правой кнопкой мыши по ней и щелкните по значку для обновления, затем нажмите кнопку «Применить» на Вверх.

после обновления ..

Обязательно закройте диспетчер синаптических пакетов, прежде чем запускать

окончательная команда

sudo do-release-upgrade  

и он должен работать.

    
ответ дан jax 06.09.2017 в 12:49