заблокирован Flash Player?

7

Когда я перехожу на сайты, использующие Flash в Firefox, я получаю это предупреждение:

  

Этот плагин уязвим, и он должен быть обновлен.

Проверка Mozilla <плагина> соглашается:

  

Adobe Flash Player Shockwave Flash 11.2 r202 уязвим 11.2.202.438

Но если я следую ссылке обновления и загружаю версию Ubuntu (открытие с помощью Software Center), я получаю

  

В ваших текущих источниках программного обеспечения нет пакета программного обеспечения под названием «adobe-flashplugin».

Если я запустил

sudo apt-get update
sudo apt-get install -y flashplugin-installer

Мне сказали

  

flashplugin-installer - это уже самая новая версия.

Итак, как я могу обновить?

    
задан Charles 30.01.2015 в 00:10
источник

5 ответов

5

Другое обновление: в настоящий момент флешка может быть заблокирована, если она не отображается как имеющая правильную версию - например. для меня в Firefox он отображается как 11.2.202.569 в Firefox (и блокирует его), но в пакете установлено 11.2.202.577 (двоичный файл flash lib также показывает 11_2_202_577 , поэтому что-то сломалось). В основном это актуально, если оно соответствует версии здесь .

UPDATE (из Ссылка ):

  

Firefox блокирует плагин Adobe Flash NPAPI для 11.2.202.481 и ранее

     

В Adobe Flash были обнаружены несколько серьезных уязвимостей безопасности   плагин с эксплойтами, которые, как известно, находятся в дикой природе. Из-за критического   характер уязвимостей, фонд Mozilla решил блок   этой версии плагина . К сожалению, во время   blocklist, только версия PPAPI плагина (как используется хром)   и пользователи Firefox обнаружили, что плагин NPAPI заблокирован   Механизм защиты от щелчка Firefox.

     

ОБНОВЛЕНИЕ: . По состоянию на 2015/07/16 Adobe выпустила 11.2.202.491, которая исправляет все известные проблемы для PPAPI и NPAPI, а обновления доступны для Ubuntu

     

Временная шкала      

  • 2015 14 июля: Adobe выпустила обновление безопасности плагинов для PPAPI NPAPI
  •   
  • 2015 14 июля: Ubuntu Security связывается с Adobe относительно NPAPI. Ubuntu сообщил, что плагин NPAPI скоро будет готов
  •   
  • 2015 Jul 14: Ubuntu выпускает плагин adobeflash и flashplugin-nonfree с обновлениями только для PPAPI
  •   
  • 2015 Jul 16: Adobe выпускает обновления для NPAPI (11.2.202.491)
  •   
  • 2015 Jul 16: Ubuntu выпускает плагин adobeflash-plugin и flashplugin-nonfree с обновлениями для NPAPI (11.2.202.491), включая   предыдущие исправления PPAPI
  •   

SecurityTeam / KnowledgeBase / FirefoxAndAdobeFlashNPAPI (последний отредактированный   2015-07-16 13:36:40 от jdstrand)

Вы можете обновить / установить его, используя:

sudo apt-get update
sudo apt-get install flashplugin-installer

(или sudo apt-get install --reinstall flashplugin-installer , sudo apt-get remove --purge flashplugin-installer && sudo apt-get install flashplugin-installer и т. д.)

или он также должен быть обновлен, если вы используете:

sudo apt-get update
sudo apt-get upgrade

В настоящее время Flash блокируется в Firefox по умолчанию во всех версиях:

  

В любом случае исправить его :

  • Откройте диспетчер надстроек («Инструменты» и «Дополнения», about:addons , Ctrl Shift + A )

  • Перейти к плагинам

  • В раскрывающемся списке рядом с «Shockwave Flash» выберите «Ask to Active»

Пожалуйста, сделайте это только в случае отчаяния - youtube , а на других сайтах теперь есть возможность использовать HTML5, который следует использовать для этого)

Это связано с незафиксированными проблемами безопасности в плагине Adobe Flash , которые могут быть широко использованы злоумышленниками.

Flash-плагин в целом очень небезопасен и должен быть заменен - ​​очевидно, Adobe и другие должны сокращать использование Flash, чтобы заменить его HTML5, WebGL и другими открытыми стандартами. Одна из причин (кроме их не может быть задана ...) , что версия Flash для Linux застрял на уровне 11.2 (версия для linux получает резервные копии безопасности в течение 5 лет с момента выпуска) обусловлена ​​предполагаемым дорожная карта , с помощью которой Adobe удалит поддержку Flash во всем мире (предположительно).

См. также:

ответ дан Wilf 14.07.2015 в 14:20
источник
1

Просто сделайте это

sudo apt-get install flashplugin-installer

    
ответ дан Trevor Clarke 30.01.2015 в 00:14
1

Я заметил, что все версии adobe flash (текущая версия во всех операционных системах) теперь заблокированы от автоматического запуска. то, что я сделал, с закрытием firefox, открыть домашний складной файл, показать скрытые файлы, затем перейти к .mozilla / firefox / *. по умолчанию и отредактировать файл pluginreg.dat для вашей версии (мой был 11.2.202.481, расположенный под входом / usr / lib / flashplugin-installer / libflashplayer.so: $ в файле) Я изменил 11 до 19 и не более раздражающее сообщение от firefox. теперь firefox считает мою версию 19.2.202.481

    
ответ дан DrTechno 14.07.2015 в 13:14
0

Проблема объясняется здесь: Ссылка Плагин для Linux небезопасен: (

    
ответ дан claudio 06.02.2015 в 11:49
0

Shockwave Flash 11.2.202.491, установленный в обычном обновлении программного обеспечения Ubuntu на 10/28/2016, по-прежнему заблокирован, насколько я могу судить.

    
ответ дан Terry 29.10.2016 в 23:48