Установить докеры на Ubuntu 16.04: не удалось найти пакет docker-ce

7

Я устанавливаю docker на Ubuntu 16.04. Я следую всем инструкциям Ссылка

(Эти инструкции одинаковы на Ссылка , но более чистые).

Когда я запускаю шаг «2. Get Docker CE», он не находит пакет docker-ce:

[email protected]:~$ sudo apt-get install docker-ce
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package docker-ce

Я проверил и добавлено репо. Я обновил свою систему, но я не получаю пакет:

Кто-нибудь знает, что здесь не так?

    
задан Chococroc 18.03.2017 в 23:25
источник

1 ответ

5

Он не работает, потому что установленный Ubuntu является 32-битным (как вы можете видеть из изображения репо, это i386).

В руководстве по установке из Docket четко указано:

  

Требования к ОС

     

Чтобы установить Docker, вам понадобится 64-разрядная версия одного   этих версий Ubuntu:

     
  • Яккеты 16.10
  •   
  • Xenial 16.04 (LTS)
  •   
  • Trusty 14.04 (LTS)
  •   

Я установил 64 бита, и все работает правильно.

    
ответ дан Chococroc 19.03.2017 в 00:20
источник