Как установить видеодрайвер Intel HD 3000?

7

Как установить новый видеодрайвер?

Мне нужно установить видеодрайвер Intel HD 3000 на моем ПК, на котором запущен Ubuntu 10.04.

    
задан carlindo 23.08.2011 в 15:46
источник

5 ответов

6

Графика Sandy Bridge, такая как HD3000, нуждается в обновлении поддержки Mesa сверх того, что доступно для Lucid.

Один из лучших PPA с версией mesa, которая имеет backports для Поддержка Sandy Bridge от Stefan Glasenhardt .

Я бы не установил установку PPA x-org, который часто цитируется. x-org edgers - как говорят сами разработчики, - очень нестабильны и могут вызывать серьезные проблемы с графикой, поскольку обновления часто и часто редко проверяются.

Поскольку вы используете современный ноутбук, вам также потребуется более современное ядро - 2.6.38, которое доступно в Synaptic Manager.

Как установить:

sudo add-apt-repository ppa:glasen/intel-driver
sudo apt-get update && sudo apt-get upgrade
sudo apt-get install linux-image-generic-lts-backport-natty linux-headers-generic-lts-backport-natty

Примечание

Работа с OP - это решение работает только для 32-битного Ubuntu. 64-разрядный Ubuntu с этим решением оставит вас с замороженной / испорченной графикой и как таковой следует избегать.

    
ответ дан fossfreedom 23.08.2011 в 19:04
2

Лучшее решение - это, вероятно, обновление до 10.10, а затем 11.04. Это уже новые драйверы.

В качестве альтернативы доступны драйверы для 10.04, с некоторым риском нестабильности:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update

Как описано на веб-сайте Ubuntu собственных форумах .

    
ответ дан Cry Havok 23.08.2011 в 17:17
0

10.04 слишком стар, чтобы заставить их работать, вам нужно обновиться до 11.04.

Но даже с этим драйверы Intel 3000 на Macbook Air (4,1 / 4,2) не будут работать должным образом из-за ошибок в ядре linux. См. Ссылка для объяснения этого. В результате вы будете нуждаться в Linux Kernel версии 3.2, чтобы они полностью работали.

    
ответ дан cweiske 09.10.2011 в 08:29
0

после того, как вы сделали то, что опубликовала "fossfreedom", просто измените следующую строку в "/ etc / default / grub"

 GRUB_CMDLINE_LINUX_DEFAULT="quite splash"

к

 GRUB_CMDLINE_LINUX_DEFAULT="quite splash i965.modeset=1"

также вы можете увидеть > > этот пост < < < < < lt ;

    
ответ дан Nico 19.01.2012 в 16:43
0

GRUB_CMDLINE_LINUX_DEFAULT="quite splash i965.modeset=0 работает на песчаном мосту. Также будьте осторожны при обновлении системы. Используйте только команду ниже:

sudo add-apt-repository ppa:glasen/intel-driver
sudo apt-get update && sudo apt-get upgrade
sudo apt-get install linux-image-generic-lts-backport-natty linux-headers-generic-lts-backport-natty

Установите lucid-1.04 и используйте код выше.

Спасибо, ребята, после долгого времени хороший пост. Огромное спасибо Гласену.

    
ответ дан prabind 07.07.2013 в 04:51