Не удалось загрузить модуль «canberra-gtk-module» ... но уже установлен

41
Gtk-Message: Failed to load module "canberra-gtk-module"

, но у меня уже установлены libcanberra-gtk-module и libcanberra-gtk3-module . (т. е. я попробовал это решение , но он уже установлен.)

Это происходит, например, при запуске ipython --pylab

Я запускаю Ubuntu 13.04 - raring.

    
задан cmo 06.09.2013 в 16:33
источник

4 ответа

48

Эта проблема может возникнуть на 64-битной машине при установке 32-разрядного программного обеспечения, требующего canberra-gtk-module. Например, acroread может вызвать эту проблему. В этом случае решение заключается в установке 32-разрядной версии:

sudo apt-get install libcanberra-gtk-module:i386

Следует оставить 64-битную версию, а также необходимо, чтобы 64-разрядные программы пытались ее использовать.

    
ответ дан R. W. Sinnet 24.09.2013 в 23:50
9

У меня была такая же проблема и решить ее с помощью решения, приведенного в этой проблемах с пусковой панелью .

sudo aptitude reinstall libcanberra-gtk-module
    
ответ дан Quentin 10.02.2016 в 15:29
6

установить gtk и модуль gtk3 должен решить его.

sudo apt install libcanberra-gtk-module libcanberra-gtk3-module
    
ответ дан croesus 16.01.2017 в 04:54
0

Возможно, слишком много, но это решило мою проблему:

$ sudo apt-get install libcanberra-gtk*
    
ответ дан Mona Jalal 24.10.2016 в 23:46