Как заставить F-ключи работать в byobu, для midnight commander (mc), htop и т. д.?

41

Я использую byobu с бэкэндом tmux на моем сервере 12.04. Я хотел бы использовать клавиши быстрого доступа для полчаса с ним, но клавиши F не работают.

Я видел несколько сообщений о проблемах здесь:

, но они устарели и, похоже, не работают для более новых версий byobu. Как я могу обойти это или использовать MC таким образом, чтобы он работал лучше?

    
задан Jorge Castro 05.06.2012 в 04:37
источник

3 ответа

60

Вы можете легко включить / выключить использование F-клавиш внутри Byobu (tmux), нажав либо:

  • shift - F12 (в tmux)

  • ctrl - a - ! (на экране)

Полное раскрытие: я являюсь автором и сторонником Byobu.

    
ответ дан Dustin Kirkland 08.06.2012 в 17:47
источник
8

В midnight commander для запуска F-ключа вы можете, например, вместо F2 :

  • Нажмите Alt + 2 .
  • Нажмите ESC , 2 (один за другим).

Возможно, более удобно, чем переключение с помощью:

  • shift - F12 (в tmux, по умолчанию by byobu)

  • ctrl - a - ! (на экране)

ответ дан takeshin 06.10.2014 в 14:11
3

Да, человек по моему сердцу:)

Короткий ответ: добавьте мой ppa ( ppa:izx/private ) и update byobu (или вручную установите Деб). Byobu будет по умолчанию screen в качестве backend с поведением F , восстановленным в старом стиле 4.x.

Длинный ответ: используйте byobu-select-backend , чтобы перейти на screen , если вы еще этого не сделали, и добавьте строку $BYOBU_PREFIX/share/byobu/keybindings/f-keys.screen.disable после строки $BYOBU_PREFIX/share/byobu/keybindings/f-keys.screen в /usr/share/byobu/keybindings/common .

Весь патч:

+++ byobu-5.17/usr/share/byobu/keybindings/common
@@ -1 +1,3 @@
 source $BYOBU_PREFIX/share/byobu/keybindings/f-keys.screen
+source $BYOBU_PREFIX/share/byobu/keybindings/f-keys.screen.disable
+
--- byobu-5.17.orig/etc/byobu/backend
+++ byobu-5.17/etc/byobu/backend
@@ -1,4 +1,4 @@
 # BYOBU_BACKEND can currently be "screen" or "tmux"
 # Override this on a per-user basis by editing "$BYOBU_CONFIG_DIR/backend"
 # or by launching either "byobu-screen" or "byobu-tmux" instead of "byobu".
-#BYOBU_BACKEND="tmux"
+BYOBU_BACKEND="screen"
    
ответ дан izx 05.06.2012 в 05:30