подключение к archive.ubuntu.com занимает слишком много времени

47

У меня есть сервер Ubuntu 11.10, который я только что установил. Теперь, если я попытаюсь сделать что-либо с apt-get , он пытается подключиться к archive.ubuntu.com .. Он остается на [Connecting to archive.ubuntu.com (2001:67c:1360:8c01::1a)] фазе, как 2 минуты, после чего он фактически начинает связываться и загружать материал ...

В конце концов, он всегда подключается, но в ожидании на [Connecting to archive.ubuntu.com (2001:67c:1360:8c01::1a)] фазе каждый раз в течение 2 минут!

У меня не было этой проблемы ранее на Ubuntu 11.10, сразу после переустановки ОС.

Любые идеи о том, что может быть проблемой?

    
задан Ahmad 26.03.2013 в 21:25
источник

3 ответа

80

Я решил это 12.10, отредактировав /etc/gai.conf и раскомментировав строку:

#
#    For sites which prefer IPv4 connections change the last line to
#
precedence ::ffff:0:0/96 100

Это позволяет сохранить IPv6 включенным, но устанавливает порядок приоритета для предпочтения IPv4 по протоколу IPv6.

    
ответ дан UberSteve 07.10.2013 в 16:57
17

Решение:

Я понял проблему. Мне пришлось отключить подключение IPv6, как указал The Lord Of Time.

Выполнение следующей команды в терминале указывает, включен ли IPv6 или нет:

cat /proc/sys/net/ipv6/conf/all/disable_ipv6

0 означает, что он включен, а 1 означает, что он отключен.

Чтобы отключить IPv6 в терминале, введите следующее:

echo "#disable ipv6" | sudo tee -a /etc/sysctl.conf
echo "net.ipv6.conf.all.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf
echo "net.ipv6.conf.default.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf
echo "net.ipv6.conf.lo.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf
sudo sysctl -p

Повторно запустите первую команду, и теперь она должна быть 1 .

    
ответ дан Ahmad 27.03.2013 в 22:31
6

Если вы хотите изменить apt-get, вы можете заставить IPv4 с помощью:

apt-get -o Acquire::ForceIPv4=true update

Чтобы сделать настройку постоянной, создайте файл 99force-ipv4 в файле /etc/apt/apt.conf.d /.

sudoedit /etc/apt/apt.conf.d/99force-ipv4

Вставьте в него следующее содержимое:

Acquire::ForceIPv4 "true";

Сохраните файл, и вам хорошо идти. Если вы хотите заставить IPv6 вместо этого, измените значение 4 на 6 в имени файла и настройках. Чтобы выбрать один из них, проверьте быстрый метод и посмотрите, какая из них работает лучше.

    
ответ дан Luke 12.07.2016 в 00:41