Как навсегда отключить функцию «сохранить сеанс» в Xubuntu?

7

Я запускаю Xubuntu 13.10 с xfce4-панелью 4.10.1 и мои сеансы продолжают невольно сохраняться . Я хорошо знаю, что это ошибка, поэтому я хотел бы спросить, знает ли кто-нибудь об обходном пути постоянно отключить / удалить эту функцию (возможно, удалив / отредактировав некоторые файлы)?

Я потратил часы на поиски и пробовал много методов уже, но ни один из них не работал или, по крайней мере, не был постоянным. Некоторые из вещей, которые я пробовал:

Как отключить сохранение сеанса Xfce в системе?
(Это в основном просто удалило галочку в приглашении выхода)

Xubuntu снова открывает приложения для последних сеансов, хотя это не должно
(Удаление кешированных сеансов не было постоянным решением)

Буду признателен за вашу помощь!

  

Мое временное решение:
Я создал простой скрипт bash и поместил   приложение запуска (которое запускает скрипт при нажатии) по моей задаче   панель. Сценарий удалит каталог "~ / .cache / sessions" и   promt выйти из системы.

     

Сценарий можно найти здесь: Ссылка

     

В основном это будет кнопка, которую вы используете для выхода из системы / перезагрузки / выключения.


Обновление: Это происходит только в том случае, если вы добавили "перезагрузку" в список в "Action Button" (кнопка с вашим именем пользователя, написанным на). Если вы перезагрузитесь, используя log out -> restart , он должен перезагрузиться нормально и не сохранить сеанс. Таким образом, временное решение, указанное выше, не является необходимым, я оставлю его там как ссылку.

    
задан Dut 01.03.2014 в 08:24
источник

3 ответа

5

Решение является двухэтапным.

  1. Отключить Automatically save sessions on logout в Settings > Sessions > General > Logout Settings . Также убедитесь, что вы отключили Save session for future logins в Logout prompt (окно, которое появляется, когда вы фактически пытаетесь выйти из системы).

    Смотрите:

  2. Вам нужно выйти из системы, удалить содержимое ~/.cache/sessions , а затем войти в чистый сеанс. (Вы также можете удалить текущий сеанс через Settings > Sessions > Session > Clear Saved Sessions .)

    Смотрите:

ответ дан landroni 01.03.2014 в 15:00
источник
2

Извините, если это не ответ, но я не могу комментировать.

У меня была такая же проблема с этой ошибкой. И я «разрешил» его, используя «удалить часть» вашего скрипта:

#!/bin/bash

#edit.1: It will be launched by root, so we have to use full path here.
DIR=/home/USERFOLDER/.cache/sessions/

delete_sessions(){
    # Deletes whatever is in DIR
    rm -r -- "$DIR"
}

is_directory(){
    if [ -d "$DIR" ]; then
        delete_sessions
    else 
        echo "wtf man, it's not there?!"
    fi
}

is_directory 

Я выполняю модифицированный сценарий этого способа при перезагрузке и завершении работы.

Это может быть настроено в соответствии с инструкциями на сайте: Ссылка

    
ответ дан jirimertin 12.05.2014 в 16:36
2

Удалить существующие сеансы:

$ rm .cache/session/*

Сделать каталог только для чтения:

$ chmod -w .cache/session

Вы можете включить сохранение сеанса, предоставив права на запись в каталоге:

$ chmod +w .cache/session

(Протестировано с Xubuntu 14.04)

    
ответ дан ern0 20.05.2014 в 20:10