Как я могу использовать беспроводную карту Realtek RTL8723BE?

47

Я установил Ubuntu 15.04 на свой ноутбук с картой Wi-Fi RTL8723BE. Но он всегда отключается от сети. Я пробовал echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf , но это не помогло. Что я могу сделать для предотвращения отключения Wi-Fi? Если я обновляюсь до ядра 4.X, это поможет?

~$ lspci -knn | grep Net -A2

09:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Hewlett-Packard Company Device [103c:2231]
    Kernel driver in use: rtl8723be


~$ rfkill list
0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no


~$ ifconfig && iwconfig && route -n && ping -c 1 google.com
eth0      Link encap:Ethernet  HWaddr 38:63:bb:cd:4a:7e  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:53 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:752 (752.0 B)  TX bytes:8445 (8.4 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3870 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3870 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:314613 (314.6 KB)  TX bytes:314613 (314.6 KB)

wlan0     Link encap:Ethernet  HWaddr c0:38:96:6d:c4:83  
          inet addr:192.168.1.205  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::c238:96ff:fe6d:c483/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15240 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14627 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:14410285 (14.4 MB)  TX bytes:2192744 (2.1 MB)

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"DIR-615"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:90:4C:08:00:0D   
          Bit Rate=150 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-22 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:186   Missed beacon:0

lo        no wireless extensions.

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    400    0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
PING google.com.Dlink (172.26.136.19) 56(84) bytes of data.
64 bytes from 19.136.26.172.in-addr.arpa (172.26.136.19): icmp_seq=1 ttl=249 time=102 ms

--- google.com.Dlink ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 102.547/102.547/102.547/0.000 ms
    
задан PlugaruT 12.06.2015 в 17:22
источник

7 ответов

66

Прежде всего удалите сделанные вами настройки.

sudo rm /etc/modprobe.d/rtl8723be.conf

Если у вас нет этого файла, ничего не получается.

Затем установите хороший драйвер

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtlwifi-new-dkms

Перезагрузитесь и наслаждайтесь

Если у вас все еще есть проблемы (низкий сигнал), вам может потребоваться добавить параметр:

echo "options rtl8723be ant_sel=2"  | sudo tee /etc/modprobe.d/rtl8723be.conf

, затем перезагрузитесь снова.

Расширение производится chili555 в этом ответе .

Это тот же драйвер, что и Ссылка , rock.new_btcoex , но упакован как dkms.

Вы можете видеть все это на ссылке

Если вам также нужна работа bluetooth, запустите также:

sudo apt-get install rtl8723au-bt-dkms linux-firmware

Примечание. В PPA добавлена поддержка ядер 4.2 и Ubuntu 15.10. Для ядра 4.2 драйвер bluetooth должен быть установлен не из PPA. В ядре 4.2 уже есть встроенная поддержка адаптера bluetooth.

Автономный справочник

Если у вас нет подключения к Интернету, вы можете загрузить пакет с помощью другого компьютера, телефона и т. д.

Пакет ЗДЕСЬ

Вам также понадобится DKMS . Вы можете найти пакет DKMS для Ubuntu 16.04 ЗДЕСЬ

Скопируйте эти два файла в папку Ubuntu Home (~ /) и запустите в терминале

sudo dpkg -i dkms*.deb rtlwifi*.deb

Затем перезагрузитесь.

Важно: Для новых ядер Ubuntu, установленных в системе с безопасной загрузкой в UEFI, модуль без знака может не загружаться. В этом случае см. ЭТО ОТВЕТ>, чтобы исправить это.

Обновление: У меня теперь есть ноутбук с этим адаптером. Он отлично работает на ядре 4.8, которое доступно в Ubuntu 16.10 и 16.04.2.

Установка настраиваемого драйвера требуется только для ядер старше 4.8.

Я предлагаю установить ядро 4.8 в Ubuntu 16.04, если он еще не установлен

sudo apt install linux-generic-16.04

После перезагрузки устройство должно работать хорошо.

Но если ваш ноутбук имеет только одну антенну и подключен к «неправильному» разъему, может потребоваться установка ant_sel=2 или and_sel=1 .

    
ответ дан Pilot6 12.06.2015 в 17:25
источник
6

Если ваш Wi-Fi упадет через некоторое время, а вы дважды загрузитесь с Windows

В HP 250 G4 (с использованием rtl8723be) у меня сначала была ошибка антенны : сигнал wifi был слишком низким:

Он был решен после установки нового драйвера и установки ant_sel=2 , как описано здесь.

Но потом появилась вторая проблема:
wifi работал нормально в течение некоторого времени (иногда 2 часа), а затем внезапно медленно и в конечном итоге отключился.
Изменение параметров (ips, fwps ...) не помогло.
Наконец, я обнаружил, что удаление Windows 8 fastboot (в энергетических настройках Windows) решило проблему.

Это подтверждено другим пользователем (см. RTL8723BE: Wifi всегда падает после 15/20 минут

    
ответ дан laugeo 02.07.2016 в 12:49
4

Что сработало для меня, это включить параметр MSI (interupt сигнала сообщения). У меня ноутбук Lenovo Z50. Мой wifi будет работать со всеми производителями ноутбуков Wi-Fi, но у меня возникла проблема с маршрутизатором WLAN в Lancorm в отеле, который я когда-то остался.

Я нашел файл sw.c в пути к папке

/home/peter/rtlwifi_new/rtl8723be

Затем в файле sw.c я добавил переменную .msi_support и инициировал ее под «false» под типом данных

rtl_mod_params rtl8723be_mod_params

то есть

static struct rtl_mod_params rtl8723be_mod_params = {
.sw_crypto = false,
.inactiveps = true,
.swctrl_lps = false,
.fwctrl_lps = true,
.msi_support = false,
};

Так как msi_support по умолчанию отключено, мы должны соответствующим образом инициализировать его как отключенный (следовательно, false),

Затем я выполнил код:

cd rtl8723be
make clean
sudo make install
sudo modprobe rtl8723be

После этого я установил параметр msi в 1, в файле

/etc/modprobe.d/rtl8723be.conf

он должен содержать

options rtl8723be fwlps=N ips=N swenc=Y msi=1

Возможно, вам придется перезагрузить компьютер и подождать несколько минут после перезапуска браузера для запуска msi.

Это работало для lenovo z50. В зависимости от вашего компьютера вы можете переключаться и выбирать вместо msi 0

    
ответ дан Der Kabiri 15.11.2015 в 21:46
2

Просто взял HP Stream 13 и уничтожил его, положил Ubuntu 15.10 на него, символизируя все домашние папки на 64-Гбайт SD-карту, чтобы расширить SSD на 32 ГБ ... Затем столкнулся с ужасной проблемой rtl8723be, которую я также заметил на Ноутбук HP 430, у которого был другой вариант.

После множества беспорядков, я наконец нашел, что на самом деле есть 2 проблемы.

  1. Драйвер WiFi нуждается в замене, как указано выше, для устранения отказов карты, требующих перезапуска сетевого менеджера или повторной сети с сетью. Обновите драйвер, как указано.

    sudo add-apt-repository ppa:hanipouspilot/rtlwifi
    sudo apt-get update
    sudo apt-get install rtlwifi-new-dkms linux-firmware
    
  2. Как только ваши выпадения исправлены, вам нужно вылечить проблему с низким уровнем сигнала ... Это немного более инвазивно. Отверните все винты снизу, даже те, что находятся под двумя задними резиновыми ножками, центральную небольшую резиновую крышку и шарнирные резиновые крышки на дне.

Аккуратно снимите верхнюю часть, щелкнув ее от основания. Аккуратно снимите крышку. Найдите сетевую карту в центре, в направлении сзади. Снимите тонкий коаксиальный кабель подключенной антенны (основной) и замените его на разъеме рядом с ним (aux). Поместите все вместе.

Драйвер для Linux использует другую антенну на этой карте с двумя антеннами, поэтому, если вы ее не поменяете, вы получите сильную потерю сигнала.

Теперь у ноутбука достаточно места для хранения, ботинки довольно быстрые и имеют полный сигнал без отсева по всему дому. Отличный ноутбук за цену, но вам нужно какое-то планирование, если вы собираетесь поставить Linux на него.

Спасибо всем за работу над этим.

    
ответ дан Paul 29.01.2016 в 00:41
1

У меня была такая же проблема, я обновил свой драйвер так же, как объяснил в Ответ Pilot6 , но он все еще часто отключается. Я отчаянно искал другое решение, когда нашел в ответ laugeo , что удаление WindowsB fastboot решает эта проблема. К несчастью, у меня только Ubuntu и нет Windows. Однако я обнаружил, что просто отключить Поддержка Legacy решает проблему!

Мне пришлось отключить поддержку Legacy в Bios следующим образом:

Bios - > Boot Option (Enter) - > Поддержка устаревших: отключено

Теперь WLAN работает отлично - больше не отключается!

    
ответ дан Adam 09.11.2016 в 19:12
0

Если вы используете последнюю версию Ubuntu, например 18.04 и выше, вы не сможете добавить репозиторий ppa [ppa: hanipouspilot / rtlwifi] из-за некоторых соображений безопасности.

Поэтому, получите этот новый драйвер wifi непосредственно из GitHub.

git clone https://github.com/lwfinger/rtlwifi_new

Постройте его.

cd rtlwifi_new
make

Наконец, установите его.

sudo make install

Вот и установлен обновленный драйвер.

    
ответ дан Sparkzz 03.10.2018 в 22:09
0

Это был тот же случай со мной. Я также попробовал rfkill список всех , но ничего не было заблокировано. Однако Wi-fi не работает должным образом.

Мой rfkill список всех

В течение 2 дней с момента установки Ubuntu 14.04 LTS я пробовал различные твики. Был почти расстроен и потерял надежду. Наконец, он работал.

Возможное решение . После попыток различных настроек я столкнулся с одним кодом, который, похоже, работает. Перейдите к терминалу, скопируйте-вставьте следующую команду и запустите ее -

эхо "опции rtl8723be fwlps = 0 swlps = 0" | sudo tee /etc/modprobe.d/rtl8723be.conf

Затем вам нужно перезагрузить один раз. Теперь я могу получить доступ к Интернету через Wi-Fi без каких-либо изменений.

Удачи!

    
ответ дан MIMO Rulz 31.01.2016 в 08:54