LibXp.so.6 отсутствует 15.10

7

Я пытаюсь установить драйвер принтера canon на 15.10. Я знаю, что это работало в более раннем дистрибутиве, но теперь установка не выполняется:

$ sudo dpkg -i o1512een_linux_CQueDEB_v2010_64.deb 
Selecting previously unselected package cque-en.
(Reading database ... 255576 files and directories currently installed.)
Preparing to unpack o1512een_linux_CQueDEB_v2010_64.deb ...
Unpacking cque-en (2.0-10) ...
Setting up cque-en (2.0-10) ...
Running CQue setup from /opt/cel
/opt/cel/bin/setup: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory

Недавно был удален libXp.so.6? Есть ли способ сделать эту установку?

Изменить: он больше не доступен в официальных источниках пакетов

    
задан panmari 11.01.2016 в 14:55
источник

7 ответов

4

Это может быть не идеальное или идеальное решение, но если вы загружаете .deb для предыдущей версии ubuntu (15.04), кажется, что она прекрасно подходит для 15.10. Программа, которая зависела от нее, начала работать сразу после того, как я ее установил.

Ссылка

    
ответ дан Chris Cox 13.01.2016 в 04:51
источник
4

Ubuntu Wily не имеет пакета с именем libXp. Единственное решение, которое я нашел, - установить его из предыдущей версии (загрузить файл deb, установить вручную). Я не могу найти никаких оправданий для этой droppage, появляется просто goof.

В Ubuntu Wily есть отчет об ошибке, но ответа нет. Ссылка

libxp.so НЕОБХОДИМО для программы SAS, коммерческой статистики.

    
ответ дан pauljohn32 21.01.2016 в 00:43
1

Для Ubuntu 16.04 (Xenial Xerus) выполняется следующее.

Добавьте следующую строку в /etc/apt/sources.list :

deb http://security.ubuntu.com/ubuntu precise-security main 

и запустите

sudo apt update
sudo apt install libxp6:i386

Суффикс :i386 необходим только в случае, если вам нужна 32-битная версия.

Вы также можете удалить исходную строку из /etc/apt/sources.list .     

ответ дан Corbie 28.10.2016 в 18:55
0

Выведенный вывод указывает, в чем проблема:

libXp.so.6: cannot open shared object file: No such file or directory

Это говорит о том, что у вас нет такой библиотеки, установленной в вашей системе.

Решение вашей проблемы заключается в установке отсутствующей библиотеки следующим образом:

 sudo apt-get install libXp

После установки отсутствующей библиотеки вы можете установить драйвер.

    
ответ дан ostendali 11.01.2016 в 16:04
0

Если вы получаете libxp , являющееся 64-битными ошибками, или не можете найти libXp , попробуйте установить libxi6:i386

    
ответ дан overflower 17.10.2016 в 16:53
0

Попробуйте эту команду, чтобы узнать, сколько пакетов в Ubuntu связано с libXm и мотивом.

sudo apt-get install libmotif*

или

sudo apt-get install libXm*

Вы можете увидеть список всех доступных пакетов lib.

    
ответ дан rangsiman 04.08.2017 в 06:34
0

Это сработало для меня:

sudo add-apt-repository ppa:zeehio/libxp
sudo apt-get update
sudo apt-get install libxp6

Внимание: для этого требуется добавить PPA, поэтому подумайте дважды b4. Чтобы удалить прогон PPA

sudo add-apt-repository --remove ppa:zeehio/libxp

Source1 , Source2

    
ответ дан user3804598 13.01.2018 в 21:39