Отключить SSLv3 в Apache2 при чистой установке сервера ubuntu 14.04.1

7

У меня есть новая версия сервера ubuntu версии 14.04.1 У меня есть apache2 с включенным SSL. Я хочу отключить SSLv3

(Я знаю, что это популярный вопрос, но я травил все другие ответы на нескольких сайтах, и я считаю, что я выполнил все шаги, которые они предлагают.)

Когда я использую команду:

nmap --script ssl-enum-ciphers -p 443 MYDOMAIN.com

Я вижу два набора шифров. Один SSLv3 и один TLSV1.0

У меня включен модуль SSL и его конфигурационный файл: /etc/apache2/mods-enabled/ssl.conf

Я изменил его, изменив строку

SSLProtocol all

к

SSLProtocol All -SSLv2 -SSLv3

Из всех документации и веб-руководств это должно отключить SSLv3.

Я перезапускаю apache с помощью команды

sudo service apache2 restart

, но изменений нет. SSLv3 все еще отображается.

Я попытался остановить сервер и повторно запустить команду, чтобы убедиться, что я не случайно проверяю неправильный сервер. Как и ожидалось, результат изменится.

Может кто-нибудь предположить, какую ошибку я делаю.

Роберт

Моя точная версия ubuntu:

[email protected]:/etc/apache2/mods-enabled# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.1 LTS
Release:    14.04
Codename:   trusty

Моя точная версия apache2:

[email protected]:~# apache2 -v
Server version: Apache/2.4.7 (Ubuntu)
Server built:   Jul 22 2014 14:36:38

Моя точная версия openssl:

[email protected]:~# openssl version
OpenSSL 1.0.1f 6 Jan 2014

Литература:

http://httpd.apache.org/docs/current/mod/mod_ssl.html#sslprotocol
    
задан Robert3452 15.10.2014 в 18:18
источник

3 ответа

5

Я обнаружил, что у меня были другие файлы конфигурации, которые перегружали эту опцию.

Можно было найти файлы, запустив:

cd /etc/apache2
grep -r "SSLProto" .
    
ответ дан Robert3452 16.10.2014 в 13:52
источник
4

SSLv2 больше не поддерживается.

Поэтому

SSLProtocol All -SSLv2 -SSLv3

не будет работать

SSLProtocol All -SSLv3

будет

    
ответ дан Fraterjan 24.09.2015 в 07:55
1

в вашем конфигурационном файле apache используйте следующие настройки:

SSLProtocol ALL -SSLv2 -SSLv3
SSLHonorCipherOrder On
SSLCipherSuite ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:RSA+AESGCM:RSA+AES:!aNULL:!MD5:!DSS

затем перезагрузите ваш apache и проверьте свой сайт на

Ссылка

Это дало мне оценку A (по состоянию на 2017 год), в то время как с моей предыдущей настройкой у меня было только F:)

Кредиты на:

Ссылка

    
ответ дан baltasvejas 20.07.2017 в 13:45