Как скомпилировать последний gvim из источника

7

Я обнаружил, что мне нужно скомпилировать последний gvim из-за ошибки, о которой я сообщил , но как я продолжаю?

    
задан Tom 06.05.2012 в 16:50
источник

1 ответ

10

Выполните следующие команды в терминале.

sudo apt-get build-dep vim-gnome

, чтобы получить все необходимые зависимости от сборки. Тогда

sudo apt-get install mercurial

, чтобы получить систему контроля версий Mercurial, необходимую для загрузки последнего исходного кода Vim. Тогда

hg clone https://vim.googlecode.com/hg/ vim

, чтобы загрузить исходный код Vim в подкаталог vim текущего каталога.

cd vim/src

, чтобы перейти в правый каталог

Теперь давайте настроим Vim для компиляции (с «огромными» функциями - см. Ссылка для описания различные наборы функций)

./configure --prefix=/usr/local --with-features=huge

Если ./configure закончил без проблем, запустите

make

, а затем

sudo make install

, и это должно быть.

Чтобы обновить Vim до последней версии, просто зайдите в каталог vim и запустите

hg pull
hg update

, а затем повторно запустите configure , make и make install .

    
ответ дан mjr 06.05.2012 в 17:10
источник