Как установить Firefox 32-разрядный ESR 52 без удаления Firefox 64-бит на 16.04

7

Мой компьютер имеет Ubuntu 16.04.2 LTS 64-bit и Firefox 52 64-bit.

Для одного из государственных веб-сайтов, потому что он использует браузер Java-плагин для подписи документов, мне нужно установить:

  1. Firefox ESR 52 . Обычный Firefox 52 больше не поддерживает Java как плагин для браузера, потому что NPAPI был удален ( источник ) .
  2. 32-разрядная версия Firefox ESR 52 . Я точно знаю, что Firefox 32-bit поддерживает только Sun Java в Windows, но не уверен, что это также ограничение на Ubuntu. Если это так, мне нужна 32-разрядная версия Firefox, а не 64-битная версия Firefox. 2

Я знаю, что могу установить 32-разрядный Firefox, например:

  1. установить Firefox в 32-разрядный терминал:

    sudo apt install firefox:i386
    

    , но установка Firefox 32-bit удалит Firefox 64-bit, который я хотел бы сохранить.

  2. скачать и извлечь Firefox 52 ESR 32-bit из 2 .

Можно ли было установить 32-разрядную версию Firefox ESR 52, а также установить 32-разрядную версию Sun Java на Ubuntu 16.04.2 LTS 64-bit без удаления 64-битного Firefox 52?

См:

  1. Поддержка плагинов был отключен кроме Flash .
  2. Скачать версию расширенной поддержки Firefox

Спасибо

    
задан folow 07.03.2017 в 19:08
источник

3 ответа

8

Попробуйте это обходное решение. Для меня после этого появились плагины , такие как Java и VLC. Я использую Ubuntu 16.04 64 бит с Mozilla Firefox 64-разрядной версии 52 (не ESR) и Java JDK 1.8.0_112

  1. Откройте Firefox и введите about: config в адресной строке и нажмите enter
  2. Нажмите « Я принимаю риск! '
  3. Щелкните правой кнопкой мыши в любом месте и выберите Новый > Boolean
  4. Введите plugin.load_flash_only в появившемся окне
  5. Задайте значение false
  6. Удалить все историю и перезагрузить Firefox

Я также использую различные правительственные сайты, которые используют java-плагин и цифровые подписи.

Попробуйте это и дайте мне знать.

Изменить : Mozilla Firefox 53 удалит флаг plugin.load_flash_only , чтобы это обходное решение больше не работало.

Команда Pale Moon сообщила, что они будут продолжать поддерживать плагины NPAPI на неопределенный срок. Чтобы установить java-плагин в Pale Moon, запустите его в терминале

sudo ln -s /usr/lib/java/jdk1.8.0_121/jre/lib/amd64/libnpjp2.so /usr/lib/mozilla/plugins/libnpjp2.so

Я тестировал java-плагин в браузере Pale Moon. 100% работает.

    
ответ дан Lijin 09.03.2017 в 18:32
2

Я использую 16.04 LTS 64-бит
Я загружаю и распаковываю 64-битный Firefox (но более старую версию - v.45) отсюда Ссылка
И после этого я закрываю свой «стандартный» ранее установленный Firefox и запускаю файл «firefox» из извлеченной папки архива версии 45.
Поэтому я открываю свой сайт и успешно запускаю Java-приложение внутри него.

P.S.
Я также обновил Java до последней версии:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer
    
ответ дан Rib47 14.03.2017 в 11:13
0

Вы можете установить новую версию в локальной папке (например, ~/applications/firefox_esr/ ), но вы не сможете запускать их одновременно. Из того, что я читал на веб-сайт Firefox , версия Linux не имеет того же ограничения, которое имеет версия Windows; поэтому вам лучше просто использовать 64-битные ESR.

У меня была аналогичная проблема, но выше было недостаточно для решения проблемы с плагином Java. Если это вас не доставит, установите SeaMonkey 2.46 (64 бит) и повторите попытку.

    
ответ дан Alexandre 09.03.2017 в 04:12