Как отключить тачпад в Ubuntu 17.10?

7

Недавно я обновился до 17.10 с 17.04, и теперь у меня нет возможности отключить тачпад на моем ноутбуке. Когда я делаю Fn + F9 (в моем случае), я вижу логотип тачпада на экране, где он отключен, но нет.

ASUS GL752

    
задан dr46ul 27.10.2017 в 11:33
источник

3 ответа

5

У меня была такая же проблема на моем Asus X555UB, но я использую команду synclient TouchpadOff=1 в скрипте @Legolas. Это работает для меня. источник

    
ответ дан Fernando Stefanello 28.10.2017 в 12:53
источник
3

Я не уверен, почему они не работают на вашем ноутбуке. Но я могу предложить общую альтернативу.

Поместите следующий код в файл, например touchpad_toggle.sh :

#!/bin/bash
STATUS='gsettings get org.gnome.desktop.peripherals.touchpad send-events'
if [ "$STATUS" = "'enabled'" ]
then
    gsettings set org.gnome.desktop.peripherals.touchpad send-events 'disabled'
else
    gsettings set org.gnome.desktop.peripherals.touchpad send-events 'enabled'
fi

Предоставьте разрешение на выполнение файла:

chmod +x touchpad_toggle.sh

Добавьте сочетание клавиш в файл из Настройки Устройства Клавиатура .

    
ответ дан Legolas 27.10.2017 в 12:51
3

Основываясь на ответах Фернандо и Леголаса, вот сценарий, который работает для меня:

#!/bin/bash
synclient -l | grep TouchpadOff | grep 1
if [ $? == 0 ]; then
  synclient TouchpadOff=0
else 
  synclient TouchpadOff=1
fi
    
ответ дан Konrad Garus 30.10.2017 в 10:42