Как установить последнюю версию R на Ubuntu 12.04 LTS? [Дубликат]

7

Я не могу загрузить последнюю версию R на моем ноутбуке Dell Vostro 14 3000 Series, работающем на Ubuntu 12.04 LTS.

Я набрал стандартные команды в терминале:

sudo apt-get update

sudo apt-get install r-base

sudo apt-get install r-base-dev

Но в результате получается R 2.14.1, устанавливаемый вместо R 3.2.0 (последняя версия) или даже 3.1.1

Я Linux / Ubuntu newb, так что, пожалуйста, руководствуйтесь этим. Ура!

    
задан Anirudh 26.04.2015 в 23:12
источник

1 ответ

10

Метод GUI

  1. В Центре программного обеспечения Ubuntu нажмите «Изменить & Источники программного обеспечения ...»
  2. На вкладке «другое программное обеспечение» нажмите «Добавить ...»
  3. Введите следующие настройки:
    • Тип: двоичный
    • URI: http://cran.fhcrc.org/bin/linux/ubuntu
    • Распространение: trusty /
    • Компоненты:
    • Комментарий: R CRAN

Это создает новый «источник программного обеспечения», который будет проверяться рядом с обычными репозиториями программного обеспечения Ubuntu / Canonical. После этого вам нужно повторно запустить sudo apt-get update , чтобы запросить новый репозиторий. После этого ваша система по умолчанию установит R из источника CRAN, а не Canonical, так как источник CRAN всегда будет иметь одинаковый или больший номер версии.

Важные примечания

  • строка URI может иметь множество разных значений, и вы должны выбрать тот, который географически близок к вам из списка Зеркала CRAN . cran.fhcrc.org находится в Сиэтле, США.
  • Линия распространения должна соответствовать «кодовому имени» вашей версии Ubuntu, которую вы можете получить, набрав lsb_release -cs в окне терминала.

Терминальный метод

Здесь есть хорошие инструкции здесь . Вкратце:

codename=$(lsb_release -c -s)
echo "deb http://cran.fhcrc.org/bin/linux/ubuntu $codename/" | sudo tee -a /etc/apt/sources.list > /dev/null
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E084DAB9
sudo add-apt-repository ppa:marutter/rdev
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install r-base r-base-dev

Снова замените cran.fhcrc.org на географически подходящий выбор из списка зеркал CRAN .

    
ответ дан drammock 27.04.2015 в 09:49
источник