Я не могу настроить ритм-бокс, поскольку gobject-introspection 1 не установлен

7

Раньше я советовал кому-то о том, как обновить до Rhythmbox до версии 2.99.1 . Однако они не могли обновиться из-за невозможности установки gobject-introspection-1.0. Я не мог им помочь.

Теперь, имея совершенно новый компьютер, я получаю ту же проблему, что и они. вот результат ov ./configure

simon@simon-TS44HR:~/Downloads/rhythmbox-2.99.1$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... yes
checking whether make supports nested variables... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for gobject-introspection... configure: error: gobject-introspection-1.0 is not installed

Я попытался установить gobject-introspection со следующими

simon@simon-TS44HR:~/Downloads/rhythmbox-2.99.1$ sudo apt-get -f install gobject-introspection
[sudo] password for simon: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
gobject-introspection is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

, поэтому я попробовал:

simon@simon-TS44HR:~/Downloads/rhythmbox-2.99.1$ sudo apt-get -f install gobject-introspection-1.0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package gobject-introspection-1.0
E: Couldn't find any package by regex 'gobject-introspection-1.0'

Я не очень хорошо разбираюсь в установке программного обеспечения должным образом, любая помощь будет оценена.

    
задан SimplySimon 13.07.2013 в 10:54
источник

1 ответ

14

Для просмотра gobject-introspection (или ./configure ) необходимо установить пакет разработки pkg-config (library). Этот пакет libgirepository1.0-dev [Rhythmbox-devel] Проблема с установкой 2.99.1 .

Я просто попробовал все это, и он работал .

    
ответ дан Alaa Ali 08.08.2013 в 19:48
источник

Ознакомьтесь с другими вопросами по меткам