Использование Compiz по умолчанию в Unity 2D

7

Мое оборудование может обрабатывать Compiz отлично, но не Unity 3D, досадно. Я ненавижу Metacity больше, чем Unity 2D, поэтому я переключил составники, используя compiz --replace . Однако это оставляет мне две проблемы:

  1. compiz --replace является временным, он вернется обратно к Metacity, путем следующей перезагрузки / входа
  2. Compiz оставляет оконный декоратор, когда окна максимизируются.
задан Oxwivi 24.10.2011 в 09:35
источник

1 ответ

15

Compiz по умолчанию Unity 2D compositor

Перейдите к терминалу и введите:

sudoedit /usr/share/gnome-session/sessions/ubuntu-2d.session

В пятой строке измените metacity на compiz :

DefaultProvider-windowmanager=compiz

Удалить украшение окон из максимизированных окон

Чтобы решить проблему декоратора окна, просто запустите в терминале либо следующее: Alt + F2 , и украшение окон сразу исчезнет:

gconftool-2 -s -t string '/apps/compiz-1/plugins/decor/screen0/options/decoration_match' '!state=maxvert'

То же самое можно сделать с помощью диспетчера параметров CompizConfig, CCSM, если вы уже установили его:

    
ответ дан Oxwivi 24.10.2011 в 09:46
источник

Ознакомьтесь с другими вопросами по меткам