Индикаторная мощность, застрявшая на первом значении после входа в систему

7

После удаления оболочки gnome индикатор батареи застрял на первом значении, которое он показывает, когда я вхожу в систему, то есть если при запуске он был на 100%, это все равно, пока батарея не умрет. Можете ли вы помочь мне решить эту проблему?

Обновление: попробовал следующую команду без эффекта

  

apt-get install-power -reinstall

UPDATE2:

# upower -d Device: /org/freedesktop/UPower/devices/line_power_AC   native-path:          AC   power supply:         yes   updated:        30 أكت, 2014 EET 09:13:30 م (1949 seconds ago)   has history:          no   has statistics:       no   line-power
    warning-level:       none
    online:              yes
    icon-name:          'ac-adapter-symbolic'

Device: /org/freedesktop/UPower/devices/battery_BAT0   native-path:    BAT0   vendor:               SMP   model:                DELL MKD6223  serial:               2093   power supply:         yes   updated:      30 أكت, 2014 EET 09:45:30 م (29 seconds ago)   has history:          yes   has statistics:       yes   battery
    present:             yes
    rechargeable:        yes
    state:               charging
    warning-level:       none
    energy:              18.4704 Wh
    energy-empty:        0 Wh
    energy-full:         33.2667 Wh
    energy-full-design:  62.16 Wh
    energy-rate:         20.0355 W
    voltage:             12.404 V
    time to full:        44.3 minutes
    percentage:          55%
    capacity:            53.5179%
    technology:          lithium-ion
    icon-name:          'battery-good-charging-symbolic'   History (charge):
    1414698330  55.000  charging

Device: /org/freedesktop/UPower/devices/DisplayDevice   power supply:  yes   updated:              01 ينا, 1970 EET 02:00:00 ص (1414698359 seconds ago)   has history:          no   has statistics:       no   battery
    present:             yes
    state:               charging
    warning-level:       none
    energy:              18.4704 Wh
    energy-full:         33.2667 Wh
    energy-rate:         20.0355 W
    time to full:        44.3 minutes
    percentage:          55%
    icon-name:          'battery-good-charging-symbolic'

Daemon:   daemon-version:  0.99.1   on-battery:      no   lid-is-closed:   no   lid-is-present:  yes   critical-action: PowerOff
    
задан Fat Mind 30.10.2014 в 09:17
источник

4 ответа

8

Неудивительно искать помощь для проблемы, тогда даже ответа нет, но и голосование за проблему влияет на мою работу. Однако я оставлю обходной путь в случае, если у кого-то еще была такая же проблема:

Проблема заключается в графическом интерфейсе. Он замерзает, поэтому его убить каждые 10 минут заставит его обновить, поэтому я сделал задание cron, чтобы сделать это:

crontab -e

Добавьте эту строку в конец файла, который будет выполняться каждые 10 минут:

*/10 * * * * pkill -f indicator-power-service
    
ответ дан Fat Mind 04.11.2014 в 13:44
источник
3

Я пробовал вышеупомянутые решения, и они не работали правильно для меня.

Я также сделал кучу других вещей, и я думаю был трюк:

    dconf reset -f /com/canonical/indicator/power/
    pkill -f indicator-power-service

После того, как я полностью перезапустился, индикатор, казалось, работал без проблем, не нужно задание cron!

Кстати, на боковой ноте «acpi -V | grep Battery» давала мне статус батареи, но «upower -d» не был. После исправления оба работают.

Кроме того, будьте осторожны с решением Mindaugas, потому что удаление upower берет с собой множество пакетов, многие из которых необходимы для входа в систему (а именно ubuntu-desktop). Обязательно сохраните список удаленных пакетов и переустановите их, или вы можете сломать свою систему! (Мне пришлось спасти себя с помощью терминала Ctrl-Alt-F1 и /var/log/dpkg.log)

Надеюсь, это поможет кому-то!

UPDATE:

Проблема действительно вернулась после моего исправления, но повторная работа:

    dconf reset -f /com/canonical/indicator/power/
    pkill -f indicator-power-service

снова исправлена ​​проблема.

Возможно, обе команды в задании cron будут в пути!

    
ответ дан David 06.09.2015 в 00:29
источник
1

Для меня проблема исправлена ​​после удаления любого программного обеспечения, связанного с gnome.

Все, что мне нужно было сделать, это следовать этому учебнику:

Как вернуть единство и удалить рабочий стол gnome?

Надеюсь, что этот ответ имеет для вас какое-либо значение.

    
ответ дан Jakub Nawała 25.03.2015 в 23:17
источник
1

У меня также была эта проблема. Чтобы решить эту проблему, я сделал:

sudo apt-get remove upower
sudo apt-get install upower
sudo apt-get install indicator-power

Выйдите из системы и войдите в систему, чтобы проверить, работает ли она.

    
ответ дан Mindaugas 05.05.2015 в 09:07
источник

Ознакомьтесь с другими вопросами по меткам