Как установить Gnome Builder IDE?

7

Gnome Builder - это среда разработки для gtk, как ее установить на Ubuntu Gnome?

    
задан Mark 30.11.2015 в 21:22
источник

3 ответа

7

Терминал:

Для его установки вам нужно будет добавить gnome3 и gnome3-staging PPAs (вам нужно будет запустить эти команды в Terminal, чтобы запустить Terminal press: CTRL + ALT + T ):

sudo apt-add-repository ppa:gnome3-team/gnome3-staging
sudo apt-add-repository ppa:gnome3-team/gnome3
sudo apt-get update

Затем запустите (чтобы избежать проблем):

sudo apt-get dist-upgrade

И наконец, чтобы установить пакет gnome-builder , вам нужно будет запустить (хотя вы можете перезагрузить свою систему после обновления вашей системы с помощью предыдущей команды):

sudo apt-get install gnome-builder

Это связано с тем, что gnome-builder доступно только в GNOME Shell 3.16 и выше, однако из-за того, что Ubuntu GNOME упакован, в настоящее время он недоступен в репозиториях, и только если вы получаете эти PPA.

Хотя для этого вам нужно будет работать в Ubuntu GNOME 15.10, так как он обновит вас до следующей стабильной версии оболочки GNOME, доступной вашей системе, а для 15.10 - GNOME Shell 3.18.

GUI:

Если вы предпочитаете использовать GUI, а не Terminal, найдите Software & Updates в Activities Overview :

ЗатемперейдитенавкладкуOtherSoftware:

НажмитеДобавить...:

Затемвведитеdebhttp://ppa.launchpad.net/gnome3-team/gnome3/ubuntuwilymain,нажмитеДобавитьисточник,введитесвойпароль,еслипоявитсяприглашение,затемнажмитеДобавить...исделайтетожесамоедляdebhttp://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntuwilymain:

Послетого,каквызакроетеокноSoftware&Updates,оноспроситвас,хотителивыперезагрузитьсвоиисточникииличто-товэтомроде,скажемтак.Послеэтоговамнужнобудетобновитьсистему,запустивSoftwareUpdater:

Иобновляявсепакеты,вкоторыхговорится,чтообновлениядоступны.

Кактольковыэтосделаете,вамможетпотребоватьсяперезагрузитьсистему.Итогдавысможетенайтиgnome-builderвпрограммномцентреUbuntu:

Чтовыможетеустановить,выполнивпоиск,азатемнажавкнопкуInstall,введясвойпарольвкоманднойстроке:

    
ответ дан user364819 30.11.2015 в 21:28
источник
4

Gnome Builder должен быть доступен для 3.16+. Однако из-за того, что Ubuntu GNOME упакован, вы не можете получить его из репозиториев в настоящее время, и единственная доступная сборка, по-видимому, для Gnome Builder 3.18 для Wily, так как в настоящее время сборка 3.16 оказалась неудачной (из here ):

Вы можете получить пакеты для Ubuntu, но пока вы, по крайней мере, должны использовать Wily 15.10 с этот PPA - если сборки для работы 3.16, это должно работать и на 15.04. Чтобы добавить PPAs:

sudo add-apt-repository ppa:gnome3-team/gnome3-staging
sudo add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get update

Обратите внимание, что если вы попытаетесь установить только gnome-builder , скорее всего, он установит некоторые другие аспекты GNOME 3.18 (на 15.10), которые стабильны, но не являются основными для Ubuntu, но также могут нарушить Unity desktop (должно быть хорошо, если вы хотите GNOME 3.18). Также может быть лучше обновить GNOME и при его установке:

sudo apt-get install gnome-shell gnome-session gnome-builder

На странице PPA:

  • You need to run 'sudo apt-get dist-upgrade' to avoid problems. Please read the output before entering 'Y' to make sure important packages won't be removed.

Также вы также можете установить другие приложения Gnome. Обратите внимание, что не все могут быть в версии 3.18.

Существуют и другие способы получения новых пакетов Gnome - вы можете попытаться создать версию Builder версии 3.16 из источника хотя. (это может быть неудачно, вам может потребоваться изменить материал, чтобы он работал, если вы изучите текущие сборки , возможно, будет возможно найти, что не так, и исправить его). Существуют также другие PPA, которые вы можете использовать ( пример ).

    
ответ дан Wilf 30.11.2015 в 21:31
источник
1

# 1 Использование JHBuild от Gnome

Сначала загрузите и установите JHBuild

sudo apt-get install apt-file docbook-xsl build-essential git-core gettext
sudo apt-file update

git clone git://git.gnome.org/jhbuild.git
cd jhbuild
./autogen.sh --simple-install
make
make install

Затем создайте и скомпилируйте gnome-builder вместе со всеми его последними зависимостями:

jhbuild build gnome-builder
jhbuild run gnome-builder

Преимущество в том, что вам не нужно иметь дело с любыми внешними PPA. Все необходимые модули построены в среде песочницы.

# 2 Компиляция из источника

Загрузите и извлеките файл source.tar.gz

./configure , чтобы найти отсутствующие зависимости

Перед компиляцией необходимо вручную разрешить и установить все необходимые зависимости.

Затем запустите make для компиляции

Тогда sudo checkinstall

Когда используется checkinstall, вы можете просто удалить, выполнив, sudo dpkg -r gnome-builder

    
ответ дан Gayan Weerakutti 23.02.2016 в 08:10
источник

Ознакомьтесь с другими вопросами по меткам