Как исправить ошибку при загрузке разделяемых библиотек: libwx_gtk2u_html-2.8.so.0 при установке BOINC?

7

Я на Ubuntu 16.04, 64 бит, и я пытаюсь запустить BOINC из командной строки, но когда я пытаюсь, я получаю эту ошибку:

svetlana@svetlana-desktop:~/Downloads$ sudo /home/svetlana/Downloads/BOINC
/run_manager
./boincmgr: error while loading shared libraries: libwx_gtk2u_html-2.8.so.0: cannot open shared object file: No such file or directory

Я также следил за этим руководством , но не помогал.

    
задан Svetlana Belkin 16.06.2016 в 17:23
источник

2 ответа

12

BOINC доступен в репозиториях Ubuntu sotware; если у вас нет особых, необычных потребностей, вы можете просто использовать эту версию. (Загрузка и установка версии с веб-сайта BOINC может привести к проблемам с зависимостями, подобным тем, с которыми вы столкнулись).

Просто запустите

sudo apt install boinc

, и у вас будет базовая установка клиента и менеджера.

Также доступны другие пакеты boinc (для SETI @ Home, Boinc Screensaver и т. д.); вы можете увидеть список Ссылка

    
ответ дан Nick Weinberg 16.06.2016 в 17:38
источник
1

Ubuntu 16.04 LTS поставляется только с libwxgtk3, однако вы можете установить то, что вам нужно из репозиториев Ubuntu 15.10, просто имейте в виду, что следующее не рекомендуется для решения этой проблемы. Найдите и загрузите следующие пакеты из Ссылка для выпуска wily . Лучше всего загрузить их в отдельную папку.

# Note: if you're not planning development you can skip the dbg and dev packages

libwxbase2.8-0_2.8.12.1+dfsg2-2ubuntu2_amd64.deb
libwxbase2.8-dbg_2.8.12.1+dfsg2-2ubuntu2_amd64.deb
libwxbase2.8-dev_2.8.12.1+dfsg2-2ubuntu2_amd64.deb
libwxgtk2.8-0_2.8.12.1+dfsg2-2ubuntu2_amd64.deb
libwxgtk2.8-dbg_2.8.12.1+dfsg2-2ubuntu2_amd64.deb
libwxgtk2.8-dev_2.8.12.1+dfsg2-2ubuntu2_amd64.deb
wx2.8-doc_2.8.12.1+dfsg2-2ubuntu2_all.deb
wx2.8-headers_2.8.12.1+dfsg2-2ubuntu2_amd64.deb

После того, как вы их получили, установите их с помощью dpkg -i <package-name>.deb . Они могут вытащить вам ошибку из-за зависимостей, а затем просто установите этот пакет, упомянутый первым, и повторите шаг.

    
ответ дан Videonauth 16.06.2016 в 17:35
источник

Ознакомьтесь с другими вопросами по меткам