Не удается найти пакет lib32bz2-1.0

44

Я пытаюсь установить Simplicity studio на Ubuntu 15.04 (64-разрядная версия), и я получаю эту ошибку

E: Unable to locate package lib32bz2-1.0
E: Couldn't find any package by regex 'lib32bz2-1.0'

Я попытался установить пакет lib32bz2-1.0, снова получаю ту же ошибку. Как установить пакет lib32bz2-1.0 на Ubuntu 15.04 (64-разрядный)

    
задан Rao 16.06.2015 в 13:35
источник

5 ответов

36

Попробуйте установить его вручную, набрав:

sudo apt-get update
sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6

Update:

, если вы удалите lib32bz2-1.0 , он будет успешно установлен.

sudo apt-get install lib32z1 lib32ncurses5 lib32stdc++6

В противном случае:

sudo dpkg --add-architecture i386

sudo apt-get update

sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 libstdc++6:i386 libfontconfig1:i386 libxext6:i386 libxrender1:i386 libgstreamer-plugins-base0.10-0:i386
    
ответ дан Bilal 16.06.2015 в 13:53
источник
43

Пакет (32 бит), который вы ищете, это libbz2-1.0:i386 , его 64-битная версия libbz2-1.0:amd64 .

Сначала включить поддержку нескольких архивов (если это еще не сделано):

sudo dpkg --add-architecture i386

Теперь запустите:

sudo apt-get update

Теперь вы можете установить пакет:

sudo apt-get install libbz2-1.0:i386
    
ответ дан heemayl 16.06.2015 в 14:17
31

Вы пытаетесь установить Android Studio на Ubuntu?

Если вы скажете: да!. Этот ответ для вас: -).

Возможно, вы пытаетесь установить студию Android с этим руководством? . Он имеет устаревшие зависимости от Ubuntu 16.04.

У этой команды есть проблемы:

  

sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc ++ 6

После нескольких поисков в Google я нашел возможное решение в этой статье: Плохая зависимость от установки команда .

Эта команда указывает 32-разрядную версию дополнительных библиотек, которые вам нужны для установки студии Android. Это работает для меня на Ubuntu 16.04:

sudo apt-get install libz1 libncurses5 libbz2-1.0:i386 libstdc++6 libbz2-1.0

Надеюсь, что это поможет: -).

    
ответ дан erknrio 31.05.2016 в 15:22
7

Это работает для меня на моем Ubuntu 15.04 (64-разрядный)

sudo apt-get install lib32z1 lib32ncurses5 libbz2-1.0:i386 lib32stdc++6
    
ответ дан Clock ZHONG 15.04.2016 в 20:43
2
sudo apt-get install libz1 libncurses5 libbz2-1.0 libstdc++6

без 32

    
ответ дан adri 10.09.2016 в 23:15