Проблемы после установки Skype 4.3

7

только что установил Skype 4.3 на моем ноутбуке (Dell Inspiron N5110) под управлением Ubuntu 14.10, следуя всем инструкциям из всех возможных источников, но когда я пытаюсь запустить его, ничего не происходит.

Что я могу сделать, чтобы заставить его работать? Вот что я получаю:

andi@Andi:~$ skype
skype: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
    
задан Matei Alexandru 02.12.2014 в 17:44
источник

4 ответа

10

Откройте окно терминала и попытайтесь запустить Skype с помощью этой команды (скопируйте и вставьте):

LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1 skype

Если это будет успешным, я предлагаю вам проверить этот ответ , чтобы получить постоянное решение.

    
ответ дан Gunnar Hjalmarsson 02.12.2014 в 20:58
источник
3

Это решение работало для меня на Ubuntu 16.04

sudo ln -st /usr/lib/i386-linux-gnu mesa/libGL.so.1

Убедитесь, что у вас установлено libgl1-mesa-glx .

    
ответ дан Med Rhamnia 15.09.2016 в 11:19
источник
0

Для подобных Ubuntu систем , я подтверждаю, что решение Gunnar Hjalmarsson работает:

LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1 skype

(проверено un xUbuntu 16.04) Однако это не работает для debian.

Решения для debian перечислены здесь , а решение для ошибки libGl - запустить

sudo ln -s /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1 /usr/lib/i386-linux-gnu/

Тогда все работает отлично! (проверено на debian нестабильно с дебианским двоичным кодом с официального сайта в ноябре 2016 года)

    
ответ дан tobiasBora 20.11.2016 в 00:26
источник
-1

Если другие, подобные мне, попадают сюда, пытаясь решить эту проблему, решением может быть переустановка шмеля со следующим:

sudo apt-get install bumblebee-nvidia --reinstall
    
ответ дан svea 14.02.2016 в 15:46
источник

Ознакомьтесь с другими вопросами по меткам