Как установить Firefox 3.6 и 4.0+ параллельно?

7

До прошлой недели у меня установлены оба Firefox 3.6 и Firefox 4.0, что было полезно для тестирования веб-приложений.

Но теперь ночной канал содержит Firefox 6 вместо Firefox 4. Я пробовал использовать стабильный канал, но это заменило Firefox 3.6.

    
задан Hendrik Brummermann 18.04.2011 в 06:33
источник

3 ответа

8

в приведенном ниже ответе «Firefox 3.6» - это установленная версия, «Firefox 4» - это еще одна версия, которую вы хотите использовать

Пакет Firefox из Mozilla можно извлечь в любой каталог, например, /opt или ваш домашний каталог. Для оптимальной совместимости я использую отдельные профили для Firefox 3.6 и 4.

  1. Загрузите Firefox из mozilla.com в свой домашний каталог. (обратите внимание, что эти пакеты построены для 32-битных систем, 64-разрядные системы могут столкнуться с такими необычными проблемами, как отсутствующие значки).
  2. Откройте терминал и извлеките архив в ~/firefox , выполнив:

    tar xjf firefox-4.0.tar.bz2
    

    (замените имя файла соответственно)

  3. Создайте каталог ~/bin , если он не существует, и сделайте ссылку с именем firefox4 в исполняемый файл Firefox 4:

    mkdir ~/bin
    ln -s ~/firefox/firefox ~/bin/firefox4
    

    Если вы ~/bin ранее не существовали, вам необходимо повторно зарегистрироваться, чтобы обновить свой путь, в котором Ubuntu ищет приложения. С этого момента вы можете запустить Firefox 4, выполнив firefox4 . Если вы хотите использовать Firefox 4 вместо версии Firefox, установленной в системе, запустите:

    ln -s ~/bin/firefox ~/bin/firefox4
    

Важно . Если вы загружаете Firefox из Mozilla, включена функция автоматического обновления Firefox. Менеджер пакетов ( apt ) не заботится об обновлении пакета Firefox из Mozilla. Чтобы проверить обновления вручную, перейдите в Справка = > Проверить наличие обновлений .

Дополнительные шаги, если вы хотите запускать Firefox 3.6 и 4 одновременно с одной командой:

  1. Создайте новый профиль для Firefox 4, запустив Диспетчер профилей:

    firefox4 -ProfileManager
    
  2. Нажмите Create Profile и введите firefox4 в качестве имени профиля. Нажмите «Готово», когда закончите.
  3. Создайте файл ~/bin/fx4 , содержащий:

    #!/bin/sh
    firefox4 --no-remote -P firefox4 "$@"
    
  4. Создайте файл ~/bin/fx , содержащий:

    #!/bin/sh
    firefox --no-remote -P default "$@"
    

    (замените default на ваше имя профиля для Firefox 3.6)
    Предполагается, что исполняемый файл Firefox - Firefox 3.6, что имеет место в Maverick (10.10), но не Natty (11.04).

  5. Сделайте его исполняемым:

    chmod +x ~/bin/fx4 ~/bin/fx
    
  6. Теперь вы можете запустить профиль Firefox 4, выполнив fx4 и Firefox 3.6, запустив fx .
ответ дан Lekensteyn 18.04.2011 в 12:59
источник
2

Вот что я сделал для проверки firefox 4 вместе с предустановленным firefox 3.6 в ubuntu 10.10. Вы можете запускать только одну версию за раз, а некоторые расширения могут не работать.

  • Загрузить firefox4
  • извлеките его где-нибудь с файловым роликом или вы можете используйте команду tar
  • создать символическую ссылку в системном пути

    sudo ln -s /path/to/firefox4/firefox /usr/local/bin/firefox4

  • запустить firefox с помощью команды firefox4 с терминала или вы можете создать и на панели.

ответ дан sagarchalise 18.04.2011 в 07:30
источник
2

Если вы загрузите пакеты firefox 4 или более поздней версии, вы можете извлечь папку и запустить скрипт в папке с именем firefox: откроется Firefox, с вашими дополнениями, настройками и закладками на месте.

ПРИМЕЧАНИЕ. Но таким образом оба браузера нельзя использовать одновременно: нужно закрыть (проверить диспетчер задач), чтобы другой запускался.

Чтобы иметь возможность запускать оба одновременно и избегать поиска совместимости с аддонами и т. д., вы можете использовать измененные версии для Mozilla Firefox ('clones ', ремаркетированные браузеры), которые не мешают друг другу, например Icecat вместо Firefox 4+ ( sudo add-apt-repository ppa:gnuzilla-team/ppa && sudo apt-get update && sudo apt-get install icecat -y ) или (если вы хотите иметь последний Firefox) Swiftweasel вместо Firefox 3.6.     

ответ дан user14544 19.04.2011 в 19:16
источник

Ознакомьтесь с другими вопросами по меткам