Не удается найти пакетный заголовок

7

Я изменил свой источник на локальный сервер. Я использую Ubuntu 12.10.

Когда я набираю apt-cache search в терминале, он ничего не показывает.

Когда я устанавливаю lightread, он показывает «Невозможно найти пакетный».

Когда я устанавливаю lightread вручную с помощью python. Он показывает

python '/home/peng/Downloads/quickly_trunk/setup.py' 
Traceback (most recent call last):
File "/home/peng/Downloads/quickly_trunk/setup.py", line 93, in <module>
data_files=[('share/icons/hicolor/128x128/apps', ['data/media/lightread.png'])]
File "/usr/lib/python2.7/dist-packages/DistUtilsExtra/auto.py", line 71, in setup
src_mark(src, 'setup.py')
File "/usr/lib/python2.7/dist-packages/DistUtilsExtra/auto.py", line 527, in src_mark
src.remove(path)
KeyError: 'setup.py'

Как решить проблему?

    
задан John Hass 17.10.2012 в 13:03
источник

3 ответа

8

Lightread - абсолютно потрясающий автономный Google Reader. Благодаря прекрасному дизайну и невероятной интеграции Ubuntu Lightread - лучший читатель RSS для Linux.

Установить Lightread в ubuntu

ppa: cooperjona / lightread ( Нажмите здесь, чтобы получить инструкции по использованию PPA. )

Откройте терминал и запустите следующие команды (для ubuntu 12.04, 12.10, 13.04)

sudo add-apt-repository ppa:cooperjona/lightread
sudo apt-get update
sudo apt-get install lightread
    
ответ дан hhlp 26.10.2012 в 14:48
источник
3

Пока нет доступных пакетов для Quantal: Ссылка

Сценарий setup.py в каталоге не предназначен для установки для создания пакета deb.

Простой способ установить это, чтобы проверить источник с панели запуска, а затем быстро создать свой собственный пакет на основе квантов:

bzr branch lp:lightread
cd lightread
quickly package --extras
sudo dpkg -i ../lighread-'version'.deb

Я не знаю, что версия быстро выплюнет, поэтому вам придется проверить. Вам может потребоваться установить пакеты bzr и quickly для загрузки и установки источника таким образом. Однако вы, возможно, уже загрузили источник, чтобы просто попробовать запустить команду quickly package --extras в каталоге загруженного источника (quick_trunk).

    
ответ дан Ian B. 18.10.2012 в 15:07
источник
3

Ошибка уже отмечена как исправленная: Ссылка Таким образом, вы должны установить Lightread через ppa.     

ответ дан Astral AO 21.10.2012 в 10:07
источник

Ознакомьтесь с другими вопросами по меткам