Обновление с 12.04.3 LTS до 14.04.1 Сбой LTS

7

Это, вероятно, уже было задано миллионы раз, но я изо всех сил пытаюсь обновить систему Ubuntu от LTS до LTS, теперь, когда обновление до 14.04.1 отсутствует. Моя система продолжает уведомлять меня об обновлении до последней версии, утверждая, что

Your current Hardware Enablement Stack (HWE) is going out of support
on 2014-08-07.  After this date security updates for critical parts (kernel
and graphics stack) of your system will no longer be available.'

Однако, когда я запускаю sudo do-release-upgrade , Ubuntu говорит, что у меня нет доступных обновлений. Кроме того, изменение параметра prompt в /etc/update-manager/release-upgrades до prompt=normal вместо prompt=lts вызывает следующую ошибку:

Checking for a new Ubuntu release
404  Not Found [IP: 91.189.91.14 80]
Err Upgrade tool
404  Not Found [IP: 91.189.91.14 80]
Fetched 0 B in 0s (0 B/s)
WARNING:root:file 'quantal.tar.gz.gpg' missing
Failed to fetch
Fetching the upgrade failed. There may be a network problem.

Это кажется мне странным, поскольку Quantal не является даже текущим выпуском, поэтому я не знаю, почему система его искала.

Люди предложили добавить флаг -d в команду do-release-upgrade , но в документации говорится, что это установит версию версии 14.04, которую я не хочу.

Любая помощь будет оценена, чтобы привлечь меня к этому препятствию.

    
задан Noel Forte 31.07.2014 в 05:48
источник

1 ответ

15

Вам нужно переустановить диспетчер обновлений. Сначала удалите / очистите его:

sudo apt-get purge update-manager-core update-notifier-common

Затем посмотрите на вывод консоли. Если он сообщает вам, что некоторые каталоги не удаляются, удалите их вручную. В моем случае:

rm -rf /var/lib/update-manager
rm -rf /var/lib/update-notifier

Если вы используете 13.04 или новее, вы также должны сделать это, чтобы очистить сообщения о кешированном обновлении:

sudo rm /var/lib/ubuntu-release-upgrader/release-upgrade-available

Затем обновите свои источники:

sudo apt-get update

Переустановите диспетчер обновлений:

sudo apt-get install update-manager-core update-notifier-common -y

Только , если вы в настоящее время находитесь на LTS и хотите перейти на последнюю версию LTS, убедитесь, что в /etc/update-manager/release-upgrades вы установили:

Prompt=lts

В противном случае (обновление любой версии до более новой версии):

Prompt=normal

Теперь dist-upgrade должен работать:

sudo apt-get dist-upgrade
    
ответ дан AWM 18.09.2014 в 09:37
источник

Ознакомьтесь с другими вопросами по меткам