Звук как от наушников, так и от громкоговорителей

48

Я думаю, этот вопрос уже был здесь ответом, но я не могу его найти. Я использую 12.04.

Update:

Проблема в том, что я слышу звук из динамиков ноутбука даже в наушниках. Наушники - это просто стандартные стереонаушники. И самое интересное, что все работало всего неделю назад.

Я попытался сыграть с настройками pulseaudio и alsamixer - никаких результатов.

    
задан Ilay 14.06.2012 в 18:26
источник

16 ответов

23

Исходное решение

  1. Перейдите к официальный сайт Realtek , принять отказ, а затем загрузить аудио драйвер для linux / unix. Вам нужно выбрать версию 3 для ядра 3 или новее.

  2. Установите необходимые инструменты для компиляции этого драйвера.

    sudo apt-get install build-essential gcc make

  3. Извлеките загруженный файл, запустите файл sudo ./install из терминала после перехода в извлеченную папку для компиляции драйвера.

  4. Прочтите файл Readme.txt для получения дополнительной информации.

  5. Установите gnome-alsamixer с помощью этой команды.

    sudo apt-get install gnome-alsamixer
    
  6. Откройте gnome-alsamixer, набрав alsamixer в тире.

  7. Выберите «Автоматический режим отключения звука» в новом окне.

Перезагрузитесь и посмотрите, исправлено ли это сейчас. (Шаг 6 и 7 могут не понадобиться) . Automute автоматически включается при перезапуске

Решение 2:

Я только что нашел другое решение:

(Он работал для меня только с профилем только S / PDIF, звуком от наушников и динамиков и не мог переключать профиль)

  1. Добавьте это ppa командой

     sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily
    
  2. Обновить список пакетов. на

    sudo apt-get update
    
  3. Затем установите пакет «alsa-hda-dkms»:

     sudo apt-get install alsa-hda-dkms
    

Перезагрузитесь и посмотрите результат!     

ответ дан Anwar 14.06.2012 в 22:07
источник
31

Выполните следующие шаги, чтобы автоматически отключать громкоговорители при подключении наушников:

  1. Открыть терминал ( Ctrl + Alt + T )
  2. Введите: alsamixer и нажмите Enter / Return
  3. Выберите правильное звуковое устройство, нажав F6
  4. Перейдите вправо с помощью (клавиша со стрелкой вправо), пока не выделите Auto-Mute
  5. Нажмите (стрелка вверх) и выберите Включено (или Линейный выход )
  6. Нажмите Esc , чтобы выйти из
ответ дан user247077 11.02.2014 в 16:18
6

У меня также была эта проблема на моем ноутбуке HP. Я нашел сообщение и возьму один из советов, который предлагает добавить две строки внизу файл /etc/modprobe.d/alsa-base.conf :

options snd-hda-intel model=laptop
options snd-hda-intel position_fix=1 enable=yes

сохранить и перезагрузиться. Это работает для меня!

    
ответ дан hiqhan 07.01.2013 в 08:55
4

Если бы эта проблема на XUbuntu 12.04, рассмотренная на этой странице, была установлена gnome-alsamixer package , запущена gnome-alsamixer , проверена опция «Чувствительность наушников» на экране GUI gnome-alsamixer, который пришел, подтвердил, что проблема решена. Спасибо!

    
ответ дан Bob 28.09.2012 в 20:27
2

Команда sudo apt-get install gnome-alsa-mixer сделала трюк для меня на моем Compaq nw8000 .

Я мог бы включить опцию Разъем для наушников , и теперь он переключает звук на наушники, когда я подключаю свои головные телефоны.

    
ответ дан crazygoda 10.12.2012 в 01:56
2

У меня была та же проблема в 13.04 с Asus X201E и я попробовал решение gnome-alsamixer , но он не удался, поскольку gnome-alsamixer разбился с помощью Не знаю, что делать для элемента микшера «Режим автоматической выключения», ». Таким образом, я открыл командную строку alsamixer и перешел в режим автоматического отключения звука с помощью стрелок (только Auto-Mut отображается в окне терминала) и установите его с Disabled на Enabled. Теперь подключение наушников отключает внутренние динамики.

    
ответ дан asterx 27.08.2013 в 11:18
2

Что сработало для меня, так это запустить alsamixer и включить опцию автоматического отключения звука. Я сделал это, когда наушники были подключены, и все началось отлично.

    
ответ дан Vishal 04.10.2013 в 22:09
1

после обновления с 15.04 - > 15.10, а теперь - 16.10 (где проблема началась)

единственное разрешение, которое сработало для меня, состояло в том, чтобы полностью переустановить

dpkg -l | grep 'alsa-'
apt-get install --reinstall  alsa-base alsa-utils
    
ответ дан user3258557 19.10.2016 в 21:56
1

Это работало для меня отлично.

  1. Измените /etc/modprobe.d/alsa-base.conf как суперпользователя с любимым текстовым редактором, например. г:.

    sudo gedit /etc/modprobe.d/alsa-base.conf
    
  2. В конце файла вставьте следующее:

    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=dell-m4-1 enable_msi=1
    
  3. Сохранить и перезагрузить.

Если это не сработает, измените во второй строке часть о model=dell-m4-1 на model=hp-m4 .

    
ответ дан Ahmed Riad 07.07.2013 в 17:03
0

Попробуйте правильно подключить наушники. Это случилось со мной один раз, а затем после правильного исправления этого штыря наушников он работал правильно.

    
ответ дан Pranit Bauva 14.06.2012 в 18:41
0

У меня была такая же точная проблема со свежей установкой Xubuntu. Я попробовал множество вещей, включая типизацию alsamixer в терминале. Опция не была для меня, чтобы включить разъем наушников. Я установил gnome-alsamixer и нашел опцию Jack Sense для наушников, проверил его и, увы, не получил звука от громкоговорителей ПК, когда подключены наушники. Это сработало для меня.     

ответ дан Jason 28.06.2014 в 08:03
0

Запуск alsamixer в терминале работал для меня, настроил его на Auto Mute, и вы должны найти, что ваш компьютер будет воспроизводить звук через тот или иной, а не оба

    
ответ дан Gordon Quinn 01.12.2014 в 14:09
0

в alsamixer, попробуйте использовать клавишу со стрелкой Up , затем переверните все до 100%, и вы увидите, что появляется правая панель. После этого отпустите клавишу со стрелкой в%, которая вам нравится. Теперь он должен быть вместе, а правый динамик будет работать с обеих сторон.

    
ответ дан Lazy Lee 11.01.2015 в 00:08
0

На Asus X551MA у меня была эта проблема, как только я заменил Windows на Ubuntu 14.04. Даже если я отключил динамики в aslamixer , они неожиданно вернутся.

Когда я добрался до третьего шага в этой процедуре устранения неполадок , похоже, все исправлено. Это сложная команда, в которой установлены различные пакеты, поэтому я не уверен, какая часть (-а) была действительно необходима:

sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install pavucontrol linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-'uname -r' libasound2; sudo apt-get -y --reinstall install linux- sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-'uname -r' libasound2; killall pulseaudio; rm -r ~/.pulse*; ubuntu-support-status; sudo usermod -aG 'cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse- access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'' 'whoami'
    
ответ дан Brian Z 12.01.2016 в 20:48
0

Просто перейдите к alsamixer (alsamixer в терминале) и используйте клавиши со стрелками вправо / влево, чтобы перейти к настройкам колонок, и нажмите M. Это отключит динамики, но не наушники.

    
ответ дан Rhys 10.09.2016 в 02:37
0

Это сработало для меня (Ubuntu 14.04 LTS работает на ноутбуке Compaq NC6120):

  1. Ctrl + Alt + T (для открытия терминала)
  2. Введите alsamixer
  3. Нажмите , пока не дойдете до опции «Чувствительность наушников»
  4. Нажмите m для включения (автоматически отключите звук динамиков при подключении наушников)
ответ дан XqRG 09.10.2016 в 04:26