Как отключить поведение Alt-Hotkey на терминале gnome?

55

Это не просто терминал gnome, но почти все окна gnome: когда вы держите клавишу «alt», вы можете нажать первую букву одного из пунктов меню. Это позволит вам прокручивать это меню, не нажимая на него напрямую.

Это нормально в любом другом окне, например, в Firefox, но на терминале gnome он крадет ключи, которые я использую для emacs! У меня мало шансов узнать о новых комбинациях клавиш, если можно избежать.

Если я не могу изолировать это только до терминала gnome, я в порядке с этим.

    
задан farleyknight 13.03.2011 в 21:48
источник

5 ответов

53

Изменить > Сочетания клавиш ... и снимите флажок «Включить ключи доступа к меню».

    
ответ дан geekosaur 13.03.2011 в 22:01
источник
4

Для терминала Gnome 3.14.1: нажмите «Редактировать» (в строке меню) > Предпочтения > Наконец, на вкладке «Общие» отмените проверку «включить мнемонику ...».

    
ответ дан Santropedro 10.01.2016 в 02:16
3

Если вы хотите сделать это глобально, вы можете попробовать этот метод ( источник ):

To disable mnemonics you should create (if it doesn't already exist) ~/.gtkrc-2.0. This file should contain the line gtk-enable-mnemonics = 0 (you can add other GTK settings if you'd like). Then, restart for the changes to take effect (you may be able to log out then log in instead).

The alt key will still make menus appear in some cases, but the mnemonics are now disabled. Hoorah!

EDIT: этот метод больше не работает. Я отправил отчет об ошибке относительно вопроса OP, чтобы мы посмотрели, как он развивается.

    
ответ дан metakermit 01.02.2013 в 23:10
3

Это действительно сводит меня с ума. Я бы хотел использовать Alt-V для пасты, поскольку он гораздо более эргономичен, чем с помощью CTRL, но это не представляется возможным из-за опции меню «Вид».

В целом это кажется ошибкой, потому что, когда я отключу горячие клавиши в настройках, я больше не могу использовать Alt-V для доступа к меню «Вид», но я также не могу использовать эту комбинацию для других вещей.

Мне удалось заставить Alt-Z работать, потому что нет меню, начинающегося с Z.

    
ответ дан Fonnae 25.03.2013 в 13:13
3

В Ubuntu 16.04 перейдите к настройкам системы - > Клавиатура - > Ярлыки - > Пусковые установки и очистите клавишу , чтобы показать HUD (или изменить его на другую клавишу)

    
ответ дан Peter 01.07.2016 в 06:17