Заменить xscreensaver С помощью gnome-screensaver (Xubuntu)

9

Недавно я использовал apt-get remove 'd xscreensaver и apt-get install ' d gnome-screensaver. Кажется, что это не сработало, потому что, когда я нажимаю элемент меню «Экран», ничего не происходит. Я попытался включить gnome-screensaver в список автозапуска приложений, но это не помогает (нужно ли его запустить, прежде чем кто-нибудь войдет в систему?). Как я могу заставить gnome-screensaver работать правильно и сделать кнопку Lock Screen делать то, что она должна? Спасибо заранее, ell.

EDIT: Я использую Xubuntu 11.04 и вывод ps aux | grep saver:

elliot    1374  0.0  0.3  27344  6024 ?        Ss   19:35   0:00 gnome-screensaver
elliot    1669  0.0  0.0   4160   848 pts/0    S+   19:48   0:00 grep --color=auto saver

Но я думаю, что приведенная выше информация теперь будет неактуальной, поскольку кажется, что теперь блокировка экрана работает , когда я блокирую экран, я получаю черный экран, и когда я перемещаю мышь, диалог разблокировки всплывает, так что теперь все, что мне нужно сделать, это установить заставку, может ли кто-нибудь помочь мне в этом?

    
задан ell 01.09.2011 в 14:00
источник

2 ответа

5

Установка

Когда вы удалили xscreensaver и установили gnome-screensaver , вам нужно выйти и войти в систему для элемента меню блокировки XFCE для работы

Настройка экранной заставки

Установка gnome-screensaver также устанавливает gnome-screensaver-preferences .

Если вы запустите это в терминале, вы увидите этот экран, который позволит вам перейти от «черного экрана» к одному из заставщиков гномов:

Интеграция с диспетчером настроек

При установке gnome-screensaver создаст файл с именем /usr/share/applications/gnome-screensaver-preferences.desktop

Чтобы интегрировать это в диспетчер настроек, замените содержимое этого файла следующим образом:

[Desktop Entry]
Name=Screensaver
Comment=Set your screensaver preferences
Icon=preferences-desktop-screensaver
Exec=gnome-screensaver-preferences
Terminal=false
Type=Application
Categories=Settings;DesktopSettings;Security;X-XFCE
NotShowIn=KDE;GNOME;
    
ответ дан fossfreedom 01.09.2011 в 18:54
источник
4

Вам не нужно удалять Xscreensaver. После установки gnome-screensaver вы можете изменить файл /usr/bin/xflock4 , чтобы уделить приоритет grome-screensaver.

Установите gnome-screensaver:

sudo apt-get install gnome-screensaver

Открыть файл:

sudo nano /usr/bin/xflock4

Найти

# Lock by xscreensaver or gnome-screensaver, if a respective daemon is running
for lock_cmd in \
"xscreensaver-command -lock" \
"gnome-screensaver-command --lock"

Заменить

for lock_cmd in \
"gnome-screensaver-command --lock" \
"xscreensaver-command -lock"

Возможно, потребуется выполнить вход и снова.

    
ответ дан MakisH 28.03.2013 в 10:03