Ошибка обновления Zimbra: версия API версии v5.14.0 для Perl не совпадает с v5.18.0

1

Я просто попытался обновить версию Zimbra с 8.0.5 до 8.7 после обновления Ubuntu с 12.04 до 14.04. Я последовал этому руководству: Ссылка , но я все еще получил эту ошибку: Perl API версии v5.14.0 из Socket не соответствует v5. 18,0 И сделали следующие шаги (просто чтобы воспроизвести:

  1. остановка zimbra (остановка zmcontrol как zimbra)
  2. обновление и обновление всех существующих пакетов: apt-get update & amp; & amp; & amp; & amp; apt-get upgrade
  3. Ubuntu Release Upgrade (как было отказано в Wiki, я всегда выбирал вариант по умолчанию, также поддерживал исходные конфигурации)
  4. Проверка версии Ubuntu: версия Linux 3.13.0-95-generic (buildd @ lgw01-58) (версия gcc 4.8.4 (Ubuntu 4.8.4-2ubuntu1 ~ 14.04.3)) # 142-Ubuntu SMP Пятница 12 августа 17:00:09 UTC 2016
  5. Перезагрузка, apt-get update & amp; & amp; & amp; apt-get upgrade, еще одна перезагрузка (только для сохранения)
  6. Загрузка и распаковка zimbra 8.7 для Ubuntu 14.04 (имя_пакета: zcs-8.7.0_GA_1659.UBUNTU14_64.20160628202701.tgz)
  7. установка PERL 5.18: apt-get install libperl5.18
  8. ./ install.sh -s

После последнего шага я получаю следующий вывод:

[email protected]:~/zcs-8.7.0_GA_1659.UBUNTU14_64.20160628202701# ./install.sh -s

Operations logged to /tmp/install.log.H0RNHBEX
Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-8.0.5.GA.5839.UBUNTU12.64
    zimbra-logger...FOUND zimbra-logger-8.0.5.GA.5839.UBUNTU12.64
    zimbra-mta...FOUND zimbra-mta-8.0.5.GA.5839.UBUNTU12.64
    zimbra-dnscache...NOT FOUND
    zimbra-snmp...FOUND zimbra-snmp-8.0.5.GA.5839.UBUNTU12.64
    zimbra-store...FOUND zimbra-store-8.0.5.GA.5839.UBUNTU12.64
    zimbra-apache...FOUND zimbra-apache-8.0.5.GA.5839.UBUNTU12.64
    zimbra-spell...FOUND zimbra-spell-8.0.5.GA.5839.UBUNTU12.64
    zimbra-convertd...NOT FOUND
    zimbra-memcached...FOUND zimbra-memcached-8.0.5.GA.5839.UBUNTU12.64
    zimbra-proxy...FOUND zimbra-proxy-8.0.5.GA.5839.UBUNTU12.64
    zimbra-archiving...NOT FOUND
    zimbra-core...FOUND zimbra-core-8.0.5.GA.5839.UBUNTU12.64
ZCS upgrade from 8.0.5 to 8.7.0 will be performed.
Checking for existing proxy service in your environment
Perl API version v5.14.0 of Socket does not match v5.18.0 at /usr/share/perl/5.18/XSLoader.pm line 92.
Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 8.
BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 8.
Compilation failed in require at bin/checkService.pl line 21.
BEGIN failed--compilation aborted at bin/checkService.pl line 21.
Error: Unable to contact the LDAP server.

Любая помощь будет оценена по достоинству. Однако у меня есть снимки LVM и полная резервная копия, но мне очень хотелось обновить их из-за кучи обновлений безопасности.

    
задан Broco 10.09.2016 в 11:14
источник

0 ответов