ошибка python, пытающаяся установить mps-youtube

1

Я пытаюсь установить программное обеспечение mps-youtube с помощью этой команды

~$ sudo -H pip install mps-youtube

, и я получаю следующий результат:

    Collecting mps-youtube
  Using cached mps-youtube-0.2.7.1.tar.gz
    Complete output from command python setup.py egg_info:
    Mps-youtube requires python 3.
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-Q3kVAJ/mps-youtube/

Откуда возникает ошибка и что я могу ее исправить? Благодаря

    
задан dr joe 26.01.2017 в 18:30
источник

1 ответ

0

Как говорили другие, сообщение указывает, что вам нужен Python 3. Это должно быть установлено по умолчанию, так что это нормально. Проблема в том, что вы используете pip , который, скорее всего, ссылается на pip2 , который для Python 2. Итак, попробуйте ту же команду, используя pip3 :

$ sudo -H pip3 install mps-youtube

Возможно, вам сначала нужно установить pip для Python 3:

$ sudo apt-get install python3-pip
    
ответ дан Timo 27.01.2017 в 10:26