Какую библиотеку мне нужно установить, если я хочу скомпилировать emacs

15

Я пытаюсь скомпилировать emacs на Ubuntu 12.04. Это потому, что я хочу использовать emacs 24.2. Но я получаю эту ошибку. Как я могу это исправить?

checking for long file names... yes
checking for X... no
checking for X... true
configure: error: You seem to be running X, but no X development libraries
were found.  You should install the relevant development files for X
and for the toolkit you want, such as Gtk+, Lesstif or Motif.  Also make
sure you have development files for image handling, i.e.
tiff, gif, jpeg, png and xpm.
If you are sure you want Emacs compiled without X window support, pass
  --without-x
to configure.
    
задан michael 06.11.2012 в 23:37
источник

2 ответа

15

Я делал это так:

sudo apt-get install build-essential texinfo libx11-dev libxpm-dev libjpeg-dev libpng-dev libgif-dev libtiff-dev libgtk2.0-dev libncurses-dev
# for gtk3 build replace libgtk2.0-dev with libgtk-3-dev

git clone --depth=1 git://git.savannah.gnu.org/emacs.git
./autogen.sh # not needed when installing from tarball
./configure
make bootstrap
sudo make install

Чтобы создать документы:

make docs
# or build just the format you want:
make info
make dvi
make html
make pdf

Но теперь я просто использую пакет

sudo add-apt-repository -y ppa:ubuntu-elisp
sudo apt-get update
sudo apt-get install emacs-snapshot
    
ответ дан Adobe 08.12.2012 в 08:40
11

Если вы запустите

sudo apt-get build-dep emacs23

, который устанавливает все, что необходимо для компиляции пакета emacs23 . Вполне вероятно, что этого достаточно для компиляции Emacs 24.2.

    
ответ дан Florian Diesch 07.11.2012 в 00:02