Как установить VLC 3.0 на Ubuntu Zesty 17.04?

9

Мне сложно установить VLC 3.0 в Ubuntu Zesty. Используя официальный PPA . Я добавил его с помощью

sudo add-apt-repository ppa:videolan/master-daily
sudo apt-get update

И apt-cache show перечислил его,

apt-cache show vlc | grep Version
Version: 3.0.0~~git20160813+r65787+62~ubuntu16.04.1
Version: 2.2.4-14ubuntu2

, но когда я пытаюсь установить 3.0.0 с sudo apt-get install vlc=3.* , я получаю

sudo apt-get install vlc=3.*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Selected version '3.0.0~~git20160813+r65787+62~ubuntu16.04.1' ( [amd64]) for 'vlc'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 3.0.0~~git20160813+r65787+62~ubuntu16.04.1) but it is not going to be installed
       Depends: libavcodec-ffmpeg56 (>= 7:2.6) but it is not installable or
                libavcodec-ffmpeg-extra56 (>= 7:2.6) but it is not installable
       Depends: libgles1-mesa (>= 7.8.1) or
                libgles1
       Recommends: vlc-plugin-notify (= 3.0.0~~git20160813+r65787+62~ubuntu16.04.1) but it is not going to be installed
       Recommends: vlc-plugin-samba (= 3.0.0~~git20160813+r65787+62~ubuntu16.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Есть ли другой PPA, который предоставляет VLC 3.0 в Ubuntu Zesty? Кажется, что libavcodec-ffmpeg56 был переименован,

$ apt-cache search libavcodec ffmpeg
libavcodec-extra57 - FFmpeg library with additional de/encoders for audio/video codecs

И что теперь vlc-3. * необходимо создать против новой библиотеки (libavcodec-extra57) и обновить ее манифест с старого имени (libavcodec-ffmpeg-extra56)

Я не могу зарегистрировать ошибку на этом потому что Launchpad не поддерживает это. Все, что я могу сделать, это напишите сопровождающий, используя контактный форум Launchpad, который я сделал. Нет ответа.

    
задан Evan Carroll 19.04.2017 в 03:31
источник

4 ответа

17

Вы можете установить оснастку vlc 3:

sudo snap install vlc

Он будет установлен вместе с вашим оригинальным vlc (если вы не удалите исходный vlc).

    
ответ дан elmicha 14.05.2017 в 17:09
источник
1

Я думаю, вы, возможно, добавили неправильный источник ppa, или ppa не работает на 100% за 17.04. Связанный ppc home говорит, что в 17.04 они должны быть где-то в /etc/apt/sources.list*

deb http://ppa.launchpad.net/videolan/master-daily/ubuntu zesty main
deb-src http://ppa.launchpad.net/videolan/master-daily/ubuntu zesty main

Из пакетов, которые он хочет установить и зависит от них, я вижу много «16.04», что не подходит для вашей системы «17.04». Как:

Version: 3.0.0~~git20160813+r65787+62~ubuntu**16.04.1**  
...  
Depends: vlc-nox (= 3.0.0~~git20160813+r65787+62~ubuntu**16.04.1**) but...  
Recommends: vlc-plugin-notify (= 3.0.0~~git20160813+r65787+62~ubuntu**16.04.1**) but...  
Recommends: vlc-plugin-samba (= 3.0.0~~git20160813+r65787+62~ubuntu**16.04.1**) but...  
    
ответ дан Xen2050 19.04.2017 в 07:44
1

Я предпочитаю flatpak над snap . Это среда с открытым исходным кодом и многокомпонентная среда для обработки песочницы и распространения для Linux. Он прост в использовании, и вы можете запускать приложения с закрытым исходным кодом, такие как Steam , Sublimetext .

Вы можете установить его через ppa или построить его прямо из github , это не займет много времени. Что я сделал для своего Ubuntu 16.04

mkdir FLATPAK; cd FLATPAK

git clone --recurse-submodules https://github.com/ostreedev/ostree.git
cd ostree
git submodule update --init
env NOCONFIGURE=1 ./autogen.sh
./configure
make
sudo make install
cd ..
git clone https://github.com/flatpak/flatpak.git
cd flatpak
./autogen.sh
make
sudo make install
cd ..
git clone https://github.com/PipeWire/pipewire.git
cd pipewire
./autogen.sh
make
sudo make install
cd ..
git clone https://github.com/flatpak/xdg-desktop-portal.git
./autogen.sh
make
sudo make install
cd ..
git clone https://github.com/flatpak/xdg-desktop-portal-gtk.git
./autogen.sh
./configure
make 
sudo make install

затем добавьте репозитории приложений для установки приложений.

flatpak --user remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

Наконец, установите VLC

flatpak --user install flathub org.videolan.VLC

и запустите его через

flatpak run org.videolan.VLC

Чтобы увидеть доступные приложения и время выполнения

 flatpak --user remote-ls -d flathub

Для получения дополнительной информации посетите Flatpak

EDIT: я добавил новые зависимости и изменил порядок последовательности установки.

    
ответ дан kenn 17.12.2017 в 11:41
0

У меня был включен PPA видео / мастер-ежедневно, хотя мое намерение состояло в том, чтобы не использовать 3.0, когда я обновился до 17.04, поэтому я продолжал использовать то, что я считал последними 2.x. Я только заметил, что некоторые значки в интерфейсе изменились и проверили диалоговое окно, чтобы узнать, что я сейчас использую 3.0.

Package: vlc
Status: install ok installed
Priority: optional
Section: video
Installed-Size: 220
Maintainer: Debian Multimedia Maintainers <[email protected]>
Architecture: amd64
Version: 3.0.0~~git20170829+r71452+74~ubuntu17.04.1
Provides: mp3-decoder
Depends: vlc-bin (= 3.0.0~~git20170829+r71452+74~ubuntu17.04.1), vlc-plugin-base (= 3.0.0~~git20170829+r71452+74~ubuntu17.04.1), vlc-plugin-qt (= 3.0.0~~git20170829+r71452+74~ubuntu17.04.1), vlc-plugin-video-output (= 3.0.0~~git20170829+r71452+74~ubuntu17.04.1), vlc-l10n (= 3.0.0~~git20170829+r71452+74~ubuntu17.04.1)
Recommends: vlc-plugin-notify (= 3.0.0~~git20170829+r71452+74~ubuntu17.04.1), vlc-plugin-samba (= 3.0.0~~git20170829+r71452+74~ubuntu17.04.1), vlc-plugin-skins2 (= 3.0.0~~git20170829+r71452+74~ubuntu17.04.1), vlc-plugin-video-splitter (= 3.0.0~~git20170829+r71452+74~ubuntu17.04.1), vlc-plugin-visualization (= 3.0.0~~git20170829+r71452+74~ubuntu17.04.1)
    
ответ дан LiveWireBT 03.09.2017 в 08:31