Как исправить ошибку отказа от прав (открытый ключ)?

9

При попытке установить связь между моим рабочим столом Ubuntu 12.10 и Fedora 19 я столкнулся с ошибкой Разрешен отказ (открытый ключ) .
Я могу войти через ssh из fedora в Ubuntu, но не наоборот.
Я даже выполнил telnet на обеих машинах через порт 22, и обе машины прослушивают, но не через ssh. Что делать? Любая идея?

Мой файл sshd_config выглядит следующим образом:

# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile    %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
GSSAPIAuthentication no
GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

Это sshd_config системы ubuntu.

    
задан Vivek Singh 27.08.2013 в 05:21
источник

3 ответа

12

Как вы уже отметили, ящик Fedora, в который вы входите, не был настроен для аутентификации паролем, только аутентификация с открытым ключом - это видно из результата ssh -v .

Таким образом, одним из решений является добавление пароля, как вы это сделали.

Другим методом было бы взять содержимое ~/.ssh/id_rsa.pub в поле Ubuntu и добавить его в файл ~/.ssh/authorized_keys в поле Fedora.

Теперь, когда вы включили аутентификацию по паролю, вы можете установить авторизованный ключ с помощью этой команды в поле Ubuntu:

$ ssh-copy-id fedora_box
    
ответ дан David Purdue 27.08.2013 в 22:29
источник
7

Извините, это моя ошибка. У меня не было

PasswordAuthentication yes

на конфигурации SSH устройства Fedora.

Решил, включив это. Благодарим за помощь.

    
ответ дан Vivek Singh 27.08.2013 в 09:45
2

Для меня мне пришлось прокомментировать ChallengeResponseAuthentication, не имея пароля для включения PasswordAuthentication.     

ответ дан David Okwii 28.08.2016 в 12:44