«Неизвестный параметр« --enable-libfaad »ОШИБКА: libfaac не найден» при настройке ffmpeg

9

Я пытаюсь установить это следующим образом:

sudo apt-get remove ffmpeg x264 libx264-dev
sudo apt-get update
sudo apt-get install build-essential subversion git-core checkinstall yasm texi2html libfaac-dev libfaad-dev libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev libsdl1.2-dev libx11-dev libxfixes-dev libxvidcore4-dev zlib1g-dev
cd
mkdir ffmpeg-x264-avfilter
cd ffmpeg-x264-avfilter
git clone git://git.videolan.org/x264.git
cd x264
./configure
make
sudo checkinstall --pkgname=x264 --pkgversion "1:0.svn'date +%Y%m%d'+'git rev-list HEAD -n 1 | head -c 7'" --backup=no --default
cd ..
svn checkout svn://svn.ffmpeg.org/soc/libavfilter
cd libavfilter
./checkout.sh
cd ffmpeg
./configure --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --enable-pthreads --enable-libfaac --enable-libfaad --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libx264 --enable-libxvid --enable-x11grab --enable-avfilter --enable-avfilter-lavf
make
sudo checkinstall --pkgname=ffmpeg-avfilter --pkgversion "4:0.5+svn'date +%Y%m%d'" --backup=no --default

Я получил следующие ошибки:

Unknown option "--enable-libfaad".
Unknown option "--enable-avfilter-lavf".
ERROR: libfaac not found

Что я делаю неправильно?

    
задан Даниил Зобов 09.06.2012 в 12:34
источник

6 ответов

23

Ну, сначала установите libfaac . Кажется, что была ошибка. Убедитесь, что apt-get install libfaac-dev работает.

Ниже приведены правильные инструкции по установке FFmpeg и x264 .

sudo apt-get update
sudo apt-get -y install build-essential checkinstall git libfaac-dev libgpac-dev \
  libjack-jackd2-dev libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev \
  libsdl1.2-dev libtheora-dev libva-dev libvdpau-dev libvorbis-dev libx11-dev \
  libxfixes-dev texi2html yasm zlib1g-dev

Затем для x264:

cd
git clone git://git.videolan.org/x264
cd x264
./configure --enable-static
make
sudo checkinstall --pkgname=x264 --pkgversion="3:$(./version.sh | \
  awk -F'[" ]' '/POINT/{print "+git"}')" --backup=no --deldoc=yes \
  --fstrans=no --default

И для FFmpeg:

cd
git clone --depth 1 git://source.ffmpeg.org/ffmpeg
cd ffmpeg
./configure --enable-gpl --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb \
  --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis \
  --enable-libx264 --enable-nonfree --enable-version3 --enable-x11grab
make
sudo checkinstall --pkgname=ffmpeg --pkgversion="5:$(date +%Y%m%d%H%M)-git" --backup=no \
  --deldoc=yes --fstrans=no --default
hash x264 ffmpeg ffplay ffprobe

Вот и все - фильтры должны автоматически включаться.

    
ответ дан slhck 09.06.2012 в 13:15
3

Я обнаружил, что в Ubuntu 12.04 libfaac-dev не был установлен, поэтому следуя этим инструкциям ( Ссылка ) Я включил репозиторий multiverse:

sudo nano /etc/apt/sources.list

Удаление хэшей в следующих строках для включения репо:

deb http://eu-west-1.ec2.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://eu-west-1.ec2.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://eu-west-1.ec2.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://eu-west-1.ec2.archive.ubuntu.com/ubuntu/ precise-updates multiverse

Run:

sudo apt-get update
sudo apt-get install libfaac-dev

Это должно решить эту ошибку.

    
ответ дан wayfarer_boy 26.11.2012 в 12:15
2

Если вы устанавливаете экземпляр ec2 ubuntu ...

вы должны обновиться до этого yasm, которого нет в репозиториях

.....

 install yasm

 wget http://www.tortall.net/projects/yasm/releases/yasm-1.2.0.tar.gz

 tar xvzf yasm-1.2.0.tar.gz

 cd yasm-1.2.0

 ./configure

 make && make install

 cd ..
    
ответ дан sirvon 08.04.2013 в 08:10
0

Хорошо, если у вас есть эта ошибка при попытке установить ffmpeg, тогда вы должны скачать lame из sourceforge

Откройте терминал и напишите ниже

wget http://downloads.sourceforge.net/project/lame/lame/3.98.4/lame-3.98.4.tar.gz?r=http%3A%2F%2Fffmpeg.zeranoe.com%2Fforum%2Fviewtopic.php%3Ff%3D5%26t%3D94&ts=1339140293&use_mirror=ignum

После загрузки попробуйте выполнить один за другим.

tar -zxvf lame-3.98.4.tar.gz

cd lame-3.98.4

./configure

make

make install

И вы сделали.

    
ответ дан Java D 14.08.2013 в 11:11
0

Я исправил ошибку libx264 , установив libavcodec-extra-53 package:

sudo apt-get install libavcodec-extra-53
    
ответ дан Ionică Bizău 21.02.2014 в 07:07
-1
  

Затем для x264:

     
    

CD

         

git clone git: //git.videolan.org/x264

         

cd x264

         

./ configure --enable-static

         

сделать

         

sudo checkinstall --pkgname = x264 --pkgversion="3: $ (./ version.sh | \      awk -F '["]' '/ POINT / {print $ 4" + git "$ 5}')" --backup = no --deldoc = yes \      --fstrans = no --default

  

Это не достаточно для статической сборки x264 не должен ссылаться на другие динамические библиотеки, используйте следующее, чтобы избежать проблем, возникающих при компиляции ffmpeg:

x264:

cd

clone git://git.videolan.org/x264

cd x264

./configure --enable-static 
--disable-opencl \ 
--disable-avs \ 
--disable-cli \ 
--disable-ffms \ 
--disable-gpac \ 
--disable-lavf \ 
--disable-swscale 

make

sudo checkinstall --pkgname=x264 --pkgversion="3:$(./version.sh | \ awk -F'[" ]' '/POINT/{print "+git"}')" --backup=no --deldoc=yes \ --fstrans=no --default
    
ответ дан Grant Thompson 19.08.2013 в 11:20