Внешний вид не меняется при переключении темы

9

Если я выбираю Radiance или Ambiance в меню, показанном на следующем рисунке, вся моя тема не изменяется. Он меняет строку заголовка.

Как я могу решить эту проблему? Или как сбросить тему по умолчанию?

    
задан Strubbl 29.10.2011 в 17:56
источник

9 ответов

4

Удаление файла ~ / .config / dconf / user решает проблему.

PS: Чтобы восстановить проблему, я сделал следующие шаги: изменение в файле /etc/lightdm/unity-greeter.conf строки

font-name=Ubuntu 11

to

font-name=Ubuntu 10

и после сохранения выполните команду

lightdm --test-mode 

Это все, что я изменил вчера. Теперь, если вы перезапустите сеанс с помощью CTRL + ALT + BACKSPACE и войдите в систему снова, ваша тема будет уродливой (как у меня на экране, снятой в моем вопросе). Кто-нибудь может это подтвердить?

    
ответ дан Strubbl 30.10.2011 в 09:02
источник
6

Установите dconf-editor, если у вас его нет, а затем перейдите к

org.gnome.settings-daemon.plugins.xsettings

и установите флажок «active». Одна вещь, которую я также заметил, когда это происходит, заключается в том, что медиа-ключи перестают работать: активируйте ключи org.gnome.settings-daemon.plugins.media. Также могут быть добавлены дополнительные плагины.

Неполадка Причина: при запуске single-greeter (командой lightdm -test-mode в моем случае), он отключает множество плагинов настроек-демона, которые необходимо вручную включить.

Я получил всю информацию из этой темы: Ссылка

    
ответ дан user35297 25.11.2011 в 03:26
2

У меня была такая же проблема после того, как я запустил unity-greeter в терминале. С этого момента моя тема больше не загружалась. Только строка заголовка может быть изменена путем выбора другой темы.

Удаление конфигурационных файлов, выход из системы, dconf-editor и т. д. не помогли мне.

Решена проблема: запустить /usr/bin/gnome-settings-daemon в терминале. Все настройки были мгновенно установлены.

Итак, я добавил его в «элементы запуска», и проблема была решена. Теперь все работает нормально.

    
ответ дан Andre Kaldenhoven 06.01.2012 в 12:46
2

В основном, вот что произошло:

Когда вы запустили Unity Greeter, он начал действительно волноваться, потому что он не должен быть запущен как обычный пользователь (хотя это возможно, я через некоторое время займусь этим).

Чтобы исправить это, вам нужно зайти в dconf-editor (установить пакет dconf-tools ), а затем перейти к Org > gnome > settings-daemon > плагинов, а затем убедитесь, что все включено.

Выйдите из системы и вернитесь, и вам должно быть хорошо!

Чтобы запустить Unity Greeter / lightDM в окне, чтобы вы могли делать скриншоты, запустите

unity-greeter --test-mode

или

lightdm --test-mode
    
ответ дан jrg 03.04.2012 в 14:47
1

Вы пробовали выходить из системы / регистрироваться? Как правило, при моей установке переключатель темы не завершается, пока я не сделаю это.

Любопытно, что некоторые из ваших десктопов, похоже, снова возвращаются к теме GNOME по умолчанию.

Кроме того, если это не сработает, вы также можете попробовать перезагрузить.

    
ответ дан Christopher Kyle Horton 29.10.2011 в 18:49
1

Я столкнулся с той же проблемой. После многих поисков я узнал, что основной проблемой является gtk 3.4.2. Я установил его для своих целей программирования. Даже вышеупомянутые решения не работали в моей системе. Поэтому я просто удалил его, и он начал работать нормально.

    
ответ дан Piyush 06.05.2012 в 10:50
1

Я столкнулся с аналогичной проблемой на Ubuntu 14.04. Я не смог изменить свою тему после перезагрузки моего компьютера. Я мог взломать проблему, выйдя из системы и запустив ее обратно. Я заметил эту проблему вскоре после установки Ubuntu и установки некоторых программ и драйверов.

Сброс единства решил проблему для меня. Я использовал инструмент настройки единства, чтобы сделать это, поскольку единство - сброс больше не разрешен:

sudo apt-get install unity-tweak-tool
unity-tweak-tool --reset-unity

Изменить Проблема вернулась, это ничего не исправить.

    
ответ дан kalu 30.12.2015 в 21:55
0

Попробуйте запустить:

    gksudo gedit /etc/xdg/autostart/gnome-settings-daemon.desktop

, а затем заменив строку:

    Exec=/usr/lib/gnome-settings-daemon/gnome-settings-daemon

с:

    Exec=bash -c "sleep 5; /usr/lib/gnome-settings-daemon/gnome-settings-daemon"

Возможно, вам потребуется увеличить число спящего режима. Я получил это от webupd8.

    
ответ дан Hippo 03.12.2011 в 14:01
0

У меня была такая же проблема в Ubuntu 13.04. Я только что установил gnome-tweak-tool и изменил текущую тему в меню темы. Он решил это.

    
ответ дан sudeeprds 15.08.2013 в 07:54