cmake 2.8.9 на Ubuntu 10.04

9

Я установил cmake , используя apt-get , а «последняя» версия - 2.8.0.

Но когда я пытаюсь использовать, мой проект требует cmake версии 2.8.9.

Я пытаюсь обновить, но без каких-либо успехов, используя apt-get .

Как я могу получить cmake 2.8.9 на Ubuntu 10.04

    
задан Victor 04.03.2013 в 12:39
источник

4 ответа

1

Вы должны сами компилировать cmake или можете обновить свой Ubuntu 10.04 LTS (до Ubuntu 12.04 LTS , а затем) на Ubuntu 12.10 , что является рекомендуемым методом, потому что поддержка 10.04 (рабочий стол) заканчивается в апреле 2013 года.

    
ответ дан BuZZ-dEE 04.03.2013 в 12:42
источник
8

откройте свой терминал с помощью ctrl + alt + t , а затем введите

wget http://www.cmake.org/files/v2.8/cmake-2.8.10.2-Linux-i386.sh
chmod +x cmake-2.8.10.2-Linux-i386.sh
./cmake-2.8.10.2-Linux-i386.sh

Надеюсь, что это поможет.

    
ответ дан Ten-Coin 04.03.2013 в 12:53
4

Способ Ubuntu / Debian для создания из источника:

sudo aptitude install devscripts
dget -x -u http://archive.ubuntu.com/ubuntu/pool/main/c/cmake/cmake_2.8.12.2-0ubuntu3.dsc
sudo aptitude build-dep cmake
cd cmake* && fakeroot dpkg-buildpackage -d
sudo dpkg -i ../cmake*deb

Это создаст локальный резерв и установит его. Замените практически любой другой пакет, в котором есть новый DSC.

    
ответ дан kert 15.10.2013 в 01:37
3

Вы можете попробовать следующее:

cd ~/Downloads/
wget http://www.cmake.org/files/v2.8/cmake-2.8.10.tar.gz
tar xzvf cmake-2.8.10.tar.gz
cd cmake-2.8.10
./configure
make -j4
sudo make install

Это работает для меня на Ubuntu 12.04. Мне пришлось закрыть и снова открыть терминал, чтобы увидеть изменение версии.

cmake --version

cmake версия 2.8.10

    
ответ дан twerdster 02.07.2015 в 08:54