Переключение раскладки клавиатуры в Lubuntu 11.10

9

Я нашел более старый поток на форумах Ubuntu, но я думаю, что сейчас есть более простое решение. Я хотел бы переключиться между немецким макетом по умолчанию и английским (США).

    
задан H3R3T1K 07.02.2012 в 22:45
источник

4 ответа

6

Вы можете использовать Lxkeymap в настройках. В меню «Настройки панели» / «Апплеты панели» есть переключатель макетов клавиатуры.

    
ответ дан C.S.Cameron 08.02.2012 в 05:41
источник
12

Как говорит арно, попробуйте:

setxkbmap -option grp:alt_shift_toggle "us,il"

(для иврита).

Чтобы сделать это постоянным:

 echo '@setxkbmap -option grp:alt_shift_toggle "us,il"' | sudo tee -a /etc/xdg/lxsession/Lubuntu/autostart
    
ответ дан user1112507 13.08.2012 в 07:11
2

Это общее решение, включающее решение других возможных проблем при настройке раскладки клавиатуры и их изменении с помощью ярлыков. Я тестировал это в Lubuntu oneiric, точном и квантовом.

- Во-первых, с помощью GUI-манипулятора для компоновки клавиатуры

Щелкните правой кнопкой мыши по кнопке «Обработчик макета клавиатуры» в LXPanel

Затем «Добавить»

Существуют разные типы макетов для одного и того же языка

Также установите ярлык (Изменить вариант макета).

  • Если GUI может не работать или нет в 11.10 и т. д.

    или настройки не соблюдаются после выхода из системы, или они не переведены на практике и т. д. (это часто случалось со мной в 11.10, а не после 12.04).

Проверить текущие параметры xkb с помощью:

setxkbmap -query

Я приведу пример с тремя языками, английским английским, французским и румынским стандартами. Для немца это «де», я думаю.

Итак, чтобы установить нас, fr, ro layout с вариантами default (us), (fr) и standard (ro), которые можно изменить с помощью клавиш ALT-SHIFT:

setxkbmap -layout "us,fr,ro" -variant ",,std" -option "grp:alt_shift_toggle"

Проверить, все ли в порядке и сделать все изменения постоянными (если gedit является предпочтительным текстовым редактором):

gksudo gedit /etc/default/keyboard

Посмотрите, что параметры соответствуют:

XKBMODEL="pc105"
XKBLAYOUT="us,fr,ro"
XKBVARIANT=",,std"
XKBOPTIONS="grp:alt_shift_toggle"

Посмотрите, что настройки в обработчике макета клавиатуры одинаковы в отношении порядка, подтипа и ярлыка.

- Другие возможные проблемы.

В 12.10 у меня была более странная проблема. Несмотря на выполнение вышеуказанных двух шагов, доступен только основной язык. Это было решено путем удаления и повторной установки всех вторичных языков (кроме основного) и добавления дополнительных языков, как на предыдущих шагах.

    
ответ дан cipricus 06.01.2013 в 15:26
1

Постоянное решение, предоставленное user1112507 , работало для меня в Lubuntu 12.04, но не в 12.10, когда setxkbmap, по-видимому, должен задерживаться перед выполнением .

Его решение, изменяющее / etc / xdg / lxsession / Lubuntu / autostart, предназначено для всех пользователей. Ниже приведено обходное решение для однопользовательского случая:

  1. Установите нужные языки.

    $ gnome-language-selector
    
  2. Создайте сценарий оболочки для выполнения setxkbmap после задержки и сохраните его в удобном месте. Запуск в фоновом режиме может ускорить процесс входа в систему. При необходимости увеличьте время сна. Замените «us, il» на нужные коды языков.

    $ echo '(sleep 2; setxkbmap -option grp:alt_shift_toggle -layout "us,il") &' > ~/setxkbmap.sh
    
  3. Сделайте исполняемый файл сценария и убедитесь, что он работает, переключая комбинацию клавиш Alt-Shift для переключения языка.

    $ chmod +x ~/setxkbmap.sh
    $ ~/setxkbmap.sh
    
  4. Создайте файл .desktop, который выполняет только что созданный сценарий оболочки. Замените «имя пользователя» на свое имя пользователя.

    $ echo '[Desktop Entry]
    Type=Application
    Name=Keyboard Language Switcher
    Exec=/home/username/setxkbmap.sh
    Icon=/usr/share/lxkeymap/media/icon.png
    ' > ~/Desktop/setxkbmap.desktop
    
  5. Выйдите из системы и снова войдите в систему, затем проверьте, нажав на новый значок на рабочем столе, а затем переключитесь на Alt-Shift.

  6. Переместите файл .desktop в файл ~ / .config / autostart

    $ mv ~/Desktop/setxkbmap.desktop ~/.config/autostart
    
  7. Выйдите из системы и снова войдите в систему, затем проверьте, переключая Alt-Shift.

ответ дан John 23.01.2013 в 19:22